in reply to linking libxml2

I need to install Apache::Pagekit module...

For the love of all that is holy and sacred, why? If you need to migrate a legacy system then I feel your pain but if you're starting from scratch please run far and fast from this "hasn't been updated in 9 years" framework into something a bit more modern like Catalyst or something built upon starman. The mod_perl/XML pipelines had their day and I, for one, am thankful they're over.