Beefy Boxes and Bandwidth Generously Provided by pair Networks
There's more than one way to do things
 
PerlMonks  

dynaloder error in ppm

by saran26 (Initiate)
on Dec 11, 2012 at 19:22 UTC ( #1008377=perlquestion: print w/ replies, xml ) Need Help??
saran26 has asked for the wisdom of the Perl Monks concerning the following question:

Hi All, I get this error: D:\Bala>cqperl server_side_email_testing.pl Can't load 'C:/Perl/site/lib/auto/Date/Calc/Calc.dll' for module Date::Calc: loa d_file:The specified module could not be found at C:/Program Files/IBM/RationalS DLC/common/lib/perl5/site_perl/5.8.6/MSWin32-x86-multi-thread/DynaLoader.pm line 229. at server_side_email_testing.pl line 12 Compilation failed in require at server_side_email_testing.pl line 12. BEGIN failed--compilation aborted at server_side_email_testing.pl line 12. When I tried to install the dynaloder using the ppm i get the error below ppm> install -force --area perl DynaLoader-Functions ppm install failed: Can't find any package that provide DynaLoader-Functions Please help me to resolve this

Comment on dynaloder error in ppm
Re: dynaloder error in ppm
by Anonymous Monk on Dec 11, 2012 at 19:28 UTC

    Please help me to resolve this

    DynaLoader-Functions has nothing to do with it

    Reinstall Date-Calc, or install it from a different PPM::Repositories.

    Also , 5.8.6 is unsupported ancient perl, if you're using it, it means you have support contract, so contact support -- also, you can always help yourself, many of those errors have been discussed thoroughly on perlmonks, super search

Re: dynaloder error in ppm
by davido (Archbishop) on Dec 11, 2012 at 19:41 UTC

    Did you upgrade your Perl installation without yet updating the non-core modules that you use? A current version of Perl wouldn't be binary compatible with an old module version. And vice versa: an old version of Perl wouldn't be binary compatible with new versions of modules.

    This is not a DynaLoader issue. Reinstall a version of Date::Calc that matches the version of Perl you're using. The easiest way is to simply use the CPAN install tools to reinstall the modules that are giving you trouble. This will ensure that your current toolchain builds and compiles the modules, which will promote compatibility. The other way would be to make sure your ppm (package manager) is pointed to repositories that match the version of Perl you're using.


    Dave

Re: dynaloder error in ppm
by bulk88 (Priest) on Dec 11, 2012 at 23:16 UTC
    You are mixing 2 different perls on your PC. You can't do that. Does "C:/Perl/site/lib/auto/Date/Calc/Calc.dll" exist on your disk? You probably have 2 Perls in your PATH environment variable.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1008377]
Approved by davido
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (16)
As of 2014-10-21 13:38 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (103 votes), past polls