Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Re: Debugging cgi-bin script

by davido (Archbishop)
on Jan 06, 2013 at 00:47 UTC ( #1011815=note: print w/ replies, xml ) Need Help??


in reply to Debugging cgi-bin script

I suspect, given the description of how the behavior differs from one system to the next, combined with the fact that simply adding a 'print' here and there changed the behavior, that you're suffering from buffering. You could try setting The special variable, $| to a true value to disable buffering on STDOUT, or just be sure to flush the output buffer with a newline at appropriate times.


Dave


Comment on Re: Debugging cgi-bin script
Replies are listed 'Best First'.
Re^2: Debugging cgi-bin script
by walkingthecow (Friar) on Jan 06, 2013 at 01:04 UTC
    One of the first things merlyn's script does (and mine as well) is sets $| to true with $|++. I still think it's possible that it could somehow be a buffering issue though.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1011815]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others romping around the Monastery: (12)
As of 2015-07-29 08:02 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (261 votes), past polls