Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re: upgrade broke perl?

by eppo (Novice)
on Jan 30, 2013 at 19:31 UTC ( #1016143=note: print w/ replies, xml ) Need Help??


in reply to upgrade broke perl?

when I try to update ubuntu, it tells me that i have unmet dependencies, and to run apt-get -f install, when i do that, i get this:

debconf: Perl may be unconfigured (Can't locate feature.pm in @INC (@I +NC contains: /usr/share/perl/5.14.2/ /etc/perl /usr/local/lib/perl/5. +10.1 /usr/local/share/perl/5.10.1 /usr/lib/perl5 /usr/share/perl5 /us +r/lib/perl/5.10 /usr/share/perl/5.10 /usr/local/lib/site_perl .) at / +usr/local/share/perl/5.10.1/Text/Tabs.pm line 15. BEGIN failed--compilation aborted at /usr/local/share/perl/5.10.1/Text +/Tabs.pm line 15. BEGIN failed--compilation aborted at /usr/local/share/perl/5.10.1/Text +/Tabs.pm line 15. Compilation failed in require at /usr/local/share/perl/5.10.1/Text/Wra +p.pm line 35. BEGIN failed--compilation aborted at /usr/local/share/perl/5.10.1/Text +/Wrap.pm line 35. Compilation failed in require at /usr/share/perl5/Debconf/Template.pm +line 10. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template +.pm line 10. Compilation failed in require at /usr/share/perl5/Debconf/Question.pm +line 8. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question +.pm line 8. Compilation failed in require at /usr/share/perl5/Debconf/Config.pm li +ne 7. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.p +m line 7. Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line +10. Compilation failed in require at (eval 1) line 4. BEGIN failed--compilation aborted at (eval 1) line 4. ) -- aborting Setting up libpam0g (1.1.3-7ubuntu2) ... Can't locate feature.pm in @INC (@INC contains: /usr/share/perl/5.14.2 +/ /etc/perl /usr/local/lib/perl/5.10.1 /usr/local/share/perl/5.10.1 / +usr/lib/perl5 /usr/share/perl5 /usr/lib/perl/5.10 /usr/share/perl/5.1 +0 /usr/local/lib/site_perl .) at /usr/local/share/perl/5.10.1/Text/Ta +bs.pm line 15. BEGIN failed--compilation aborted at /usr/local/share/perl/5.10.1/Text +/Tabs.pm line 15. BEGIN failed--compilation aborted at /usr/local/share/perl/5.10.1/Text +/Tabs.pm line 15. Compilation failed in require at /usr/local/share/perl/5.10.1/Text/Wra +p.pm line 35. BEGIN failed--compilation aborted at /usr/local/share/perl/5.10.1/Text +/Wrap.pm line 35. Compilation failed in require at /usr/share/perl5/Debconf/Template.pm +line 10. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Template +.pm line 10. Compilation failed in require at /usr/share/perl5/Debconf/Question.pm +line 8. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Question +.pm line 8. Compilation failed in require at /usr/share/perl5/Debconf/Config.pm li +ne 7. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Config.p +m line 7. Compilation failed in require at /usr/share/perl5/Debconf/Log.pm line +10. Compilation failed in require at /usr/share/perl5/Debconf/Db.pm line 7 +. BEGIN failed--compilation aborted at /usr/share/perl5/Debconf/Db.pm li +ne 7. Compilation failed in require at /usr/share/debconf/frontend line 6. BEGIN failed--compilation aborted at /usr/share/debconf/frontend line +6. dpkg: error processing libpam0g (--configure): subprocess installed post-installation script returned error exit sta +tus 2 Errors were encountered while processing: libpam0g E: Sub-process /usr/bin/dpkg returned an error code (1)
any idea on how to fix this? thanks for your help. Joe


Comment on Re: upgrade broke perl?
Download Code

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1016143]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (5)
As of 2014-10-23 03:11 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (123 votes), past polls