Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight
 
PerlMonks  

Can't install MakeMaker

by VTBlogger (Initiate)
on Feb 03, 2013 at 06:12 UTC ( #1016779=perlquestion: print w/ replies, xml ) Need Help??
VTBlogger has asked for the wisdom of the Perl Monks concerning the following question:

Hi. I'm trying to do a manual install of MakeMaker, since my firewalls at work prevent my using cpan/ppm. I download and unpack the tar file as usual, then do the perl Makefile.PL thing, at which point it tells me that I'm missing my\bundles.pm. Since I have an empty 'my' directory from the unzipped tar file, I moved a copy of bundles.pm there. The run of Makefile.PL then complained that virtually every file was missing from my kit, though they were all in the unpacked file. HELP!

Comment on Can't install MakeMaker
Re: Can't install MakeMaker
by Plankton (Priest) on Feb 03, 2013 at 07:34 UTC
    What version of Perl are you running. I believe "ExtUtils::MakeMaker" is a core modules. What do you get when you execute ...
    perl -v perl -MExtUtils::MakeMaker -e1;
      I needed 6.62 or up for another module; my perl install came with 6.50.
Re: Can't install MakeMaker (ptar)
by Anonymous Monk on Feb 03, 2013 at 07:37 UTC
      Bingo! I used WinZip, which didn't completely unpack it for some reason. Now I just have to figure out a "need JSON 2.5" bit and I should be good. Many thanks!

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1016779]
Approved by kcott
Front-paged by cavac
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (10)
As of 2014-10-23 04:54 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (124 votes), past polls