Beefy Boxes and Bandwidth Generously Provided by pair Networks Bob
Perl-Sensitive Sunglasses
 
PerlMonks  

Error encountered while installing PDF::OCR2

by bobproct (Initiate)
on Apr 07, 2013 at 20:41 UTC ( #1027396=perlquestion: print w/ replies, xml ) Need Help??
bobproct has asked for the wisdom of the Perl Monks concerning the following question:

Error encountered while installing PDF::OCR2

I'm wanting to install PSDF::OCR2, a module with several dependencies. The one module that seems to be causing problems is PDF::GetImages. Most of the other dependencies have been installed OK. Here are the installed modules.

Roberts-MacBook-Pro:WORK_DIR_XXX rproctor$ instmodsh Name "main::running_under_some_shell" used only once: possible typo at + /usr/bin/instmodsh5.12 line 3. Available commands are: l - List all installed modules m <module> - Select a module q - Quit the program cmd? l Installed modules are: App::cpanminus Bundle::NetSNMP CAM::PDF CPAN::Meta CPAN::Meta::Requirements CPAN::Meta::YAML Crypt::RC4 Devel::Symdump ExtUtils::MakeMaker File::Path File::PathInfo File::PathInfo::Ext File::Type File::Which File::chmod Font::TTF Getopt::Std::Strict IPC::Run3 JSON::PP LEOCHARRE::CLI LEOCHARRE::CLI2 LEOCHARRE::Class2 LEOCHARRE::Debug LEOCHARRE::Dir Linux::usermod Module::Build Module::Metadata PDF::API2 PDF::Burst Parse::CPAN::Meta Perl Perl::OSType Probe::Perl Smart::Comments String::ShellQuote Test::Script Text::PDF Time::Format YAML mod_perl2 version cmd? q Roberts-MacBook-Pro:WORK_DIR_XXX rproctor$ sudo cpan PDF::GetImages

Here is the Console:

Roberts-MacBook-Pro:PDF-GetImages-1.18 rproctor$ cpanm PDF::GetImage /Users/rproctor/.cpanm/build.log: Permission denied at /loader/0x7fb7f +403ffc0/App/cpanminus/script.pm line 202. Roberts-MacBook-Pro:PDF-GetImages-1.18 rproctor$ sudo cpanm PDF::GetIm +age Password: ! Finding PDF::GetImage on cpanmetadb failed. ! Finding PDF::GetImage on search.cpan.org failed. ! Finding PDF::GetImage on mirror http://search.cpan.org/CPAN failed. ! Couldn't find module or a distribution PDF::GetImage Roberts-MacBook-Pro:PDF-GetImages-1.18 rproctor$ sudo cpanm PDF::GetIm +ages --> Working on PDF::GetImages Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/PDF-Get +Images-1.18.tar.gz ... OK Configuring PDF-GetImages-1.18 ... N/A ! Configure failed for PDF-GetImages-1.18. See /Users/rproctor/.cpanm/ +build.log for details. Roberts-MacBook-Pro:PDF-GetImages-1.18 rproctor$

Here is the build.log file

cpanm (App::cpanminus) 1.4008 on perl 5.012004 built for darwin-thread +-multi-2level Work directory is /Users/rproctor/.cpanm/work/1365358841.74179 You have make /usr/bin/make You have LWP 6.03 You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3 You have /usr/bin/unzip Searching PDF::GetImages on cpanmetadb ... --> Working on PDF::GetImages Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/PDF-Get +Images-1.18.tar.gz -> OK Unpacking PDF-GetImages-1.18.tar.gz Entering PDF-GetImages-1.18 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.64) Configuring PDF-GetImages-1.18 Running Makefile.PL Cannot find pdfimages executable. -> N/A -> FAIL Configure failed for PDF-GetImages-1.18. See /Users/rproctor/. +cpanm/build.log for details.

Any suggestions for fixing this problem?

Comment on Error encountered while installing PDF::OCR2
Select or Download Code
Re: Error encountered while installing PDF::OCR2
by marto (Chancellor) on Apr 07, 2013 at 21:45 UTC

    It's important to read the documentation for modules you're trying to install. PDF::GetImages:

    "Get images out of a pdf document. This code makes use of pdfimages which is part of xpdf."

    Install the xpdf package for your platform.

      I'm wanting to install PDF::OCR2. I got past the previous problem. Thanks very much to marto for mentioning my oversight of the Xpdf dependency.

      I'm running on a Retina MacBook Pro (MacBookPro10,1) 16 GB with OS X 10.8.3.

      Now I'm having a problem installing the Image::OCR::Tesseract dependency.

      Here is my console:

      Roberts-MacBook-Pro:Perl_Modules rproctor$ sudo cpanm PDF::OCR2 Password: --> Working on PDF::OCR2 Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/PDF-OCR +2-1.21.tar.gz ... OK Configuring PDF-OCR2-1.21 ... OK ==> Found dependencies: Image::OCR::Tesseract --> Working on Image::OCR::Tesseract Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/Image-O +CR-Tesseract-1.24.tar.gz ... OK Configuring Image-OCR-Tesseract-1.24 ... N/A ! Configure failed for Image-OCR-Tesseract-1.24. See /Users/rproctor/. +cpanm/build.log for details. ! Bailing out the installation for PDF-OCR2-1.21. Retry with --prompt +or --force. Roberts-MacBook-Pro:Perl_Modules rproctor$

      Here is the build.log file

      cpanm (App::cpanminus) 1.4008 on perl 5.012004 built for darwin-thread +-multi-2level Work directory is /Users/rproctor/.cpanm/work/1365451076.5809 You have make /usr/bin/make You have LWP 6.03 You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3 You have /usr/bin/unzip Searching Image::OCR::Tesseract on cpanmetadb ... --> Working on Image::OCR::Tesseract Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/Image-O +CR-Tesseract-1.24.tar.gz -> OK Unpacking Image-OCR-Tesseract-1.24.tar.gz Entering Image-OCR-Tesseract-1.24 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.64) Configuring Image-OCR-Tesseract-1.24 Running Makefile.PL Cannot find convert executable. -> N/A -> FAIL Configure failed for Image-OCR-Tesseract-1.24. See /Users/rpro +ctor/.cpanm/build.log for details.

      I looked around but didn't find any clue on whereabouts of 'convert'. Any suggestions for fixing this problem? Thanks.

        Cannot find convert executable.

        The INSTALL file says:

        # INSTALL # ====== # # You will need to have accessible to perl the paths to executables: t +esseract and convert # You will need ImageMagick installed. # If the executables are not installed, testing will be incomplete, in +stallation will still take place.

        The documentation says:

        Included in this package is t/tesseract_install_helper.pl which will c +heck for packages needed.

        So you need to install the ImageMagick software for your platform.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1027396]
Approved by marto
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others having an uproarious good time at the Monastery: (9)
As of 2014-04-23 21:35 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (555 votes), past polls