Beefy Boxes and Bandwidth Generously Provided by pair Networks
Pathologically Eclectic Rubbish Lister
 
PerlMonks  

Re^4: Error encountered while installing PDF::OCR2

by bobproct (Initiate)
on Apr 09, 2013 at 12:30 UTC ( #1027719=note: print w/ replies, xml ) Need Help??


in reply to Re^3: Error encountered while installing PDF::OCR2
in thread Error encountered while installing PDF::OCR2

I'm wanting to install PSDF::OCR2. Thanks very much to marto for helping. I am having a problem installing the Image::OCR::Tesseract dependency and you suggested that I needed to install Image::Magick

I'm now seeing an error when installing Image::Magick: Magick.xs:60:10: fatal error: 'magick/MagickCore.h' file not found

A posting in StackOverflow http://stackoverflow.com/questions/12996578/how-to-tell-cpanm-imagemagick-about-header-location suggested "edit Makefile.PL (add header dir to includes)". Is that what should be done? What is the correct syntax for doing that?

I don't have much experience doing this and appreciate any help.

Here is my console:

Roberts-MacBook-Pro:PerlMagick rproctor$ sudo cpanm Image::Magick Password: --> Working on Image::Magick Fetching http://search.cpan.org/CPAN/authors/id/J/JC/JCRISTY/PerlMagic +k-6.82.0.tar.gz ... OK Configuring PerlMagick-6.82.0 ... OK Building and testing Image-Magick-6.82 ... FAIL ! Installing Image::Magick failed. See /Users/rproctor/.cpanm/build.lo +g for details. Roberts-MacBook-Pro:PerlMagick rproctor$

Here is the build.log file

cpanm (App::cpanminus) 1.4008 on perl 5.012004 built for darwin-thread +-multi-2level Work directory is /Users/rproctor/.cpanm/work/1365508042.5742 You have make /usr/bin/make You have LWP 6.03 You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3 You have /usr/bin/unzip Searching Image::Magick on cpanmetadb ... --> Working on Image::Magick Fetching http://search.cpan.org/CPAN/authors/id/J/JC/JCRISTY/PerlMagic +k-6.82.0.tar.gz -> OK Unpacking PerlMagick-6.82.0.tar.gz Entering PerlMagick-6.82 META.yml not found or unparsable. Fetching META.yml from search.cpan.o +rg Configuring PerlMagick-6.82.0 Running Makefile.PL Checking if your kit is complete... Looks good Warning (mostly harmless): No library found for -lMagickCore-Q16 Warning (mostly harmless): No library found for -lperl Writing Makefile for Image::Magick Writing MYMETA.yml and MYMETA.json -> OK Checking dependencies from MYMETA.yml ... Finding PREREQ from Makefile ... Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.64) Building and testing Image-Magick-6.82 cp Magick.pm blib/lib/Image/Magick.pm AutoSplitting blib/lib/Image/Magick.pm (blib/lib/auto/Image/Magick) /usr/bin/perl /System/Library/Perl/5.12/ExtUtils/xsubpp -typemap /Sys +tem/Library/Perl/5.12/ExtUtils/typemap -typemap typemap Magick.xs > +Magick.xsc && mv Magick.xsc Magick.c clang -c -I/usr/local/include/ImageMagick -DMAGICKCORE_HDRI_ENABLE=0 +-DMAGICKCORE_QUANTUM_DEPTH=16 -I/usr/include/libxml2 -I"/usr/include/ +ImageMagick" -arch i386 -arch x86_64 -g -pipe -fno-common -DPERL_DARW +IN -fno-strict-aliasing -fstack-protector -I/usr/local/include -I/usr +/include/freetype2 -fopenmp -g -O2 -Wall -pthread -DMAGICKCORE_HDRI_E +NABLE=0 -DMAGICKCORE_QUANTUM_DEPTH=16 -Os -DVERSION=\"6.82\" -DXS_V +ERSION=\"6.82\" "-I/System/Library/Perl/5.12/darwin-thread-multi-2le +vel/CORE" -D_LARGE_FILES=1 -DHAVE_CONFIG_H Magick.c clang: warning: argument unused during compilation: '-fopenmp' Magick.xs:60:10: fatal error: 'magick/MagickCore.h' file not found #include <magick/MagickCore.h> ^ 1 error generated. make: *** [Magick.o] Error 1 -> FAIL Installing Image::Magick failed. See /Users/rproctor/.cpanm/bu +ild.log for details.

Any suggestions for fixing this problem?


Comment on Re^4: Error encountered while installing PDF::OCR2
Select or Download Code
Re^5: Error encountered while installing PDF::OCR2
by hdb (Prior) on Apr 09, 2013 at 12:36 UTC
Re^5: Error encountered while installing PDF::OCR2
by marto (Chancellor) on Apr 09, 2013 at 12:41 UTC

      I'm wanting to install PSDF::OCR2. Thanks very much to marto for helping.

      ImageMagick is now installed. I don't get the message about the missing convert executable any more

      I see LEOCHARRE::CLI in installed modules but it must be defective because it's being re-built, and then it fails.

      Installed modules

      Roberts-MacBook-Pro:~ rproctor$ sudo instmodsh Password: Available commands are: l - List all installed modules m <module> - Select a module q - Quit the program cmd? l Installed modules are: CPAN::Meta::Requirements CPAN::Meta::YAML Devel::Symdump ExtUtils::MakeMaker File::Find::Rule File::Type File::Which File::chmod Font::TTF Getopt::Std::Strict IPC::Run3 JSON::PP LEOCHARRE::CLI LEOCHARRE::DEBUG LEOCHARRE::Debug LEOCHARRE::Dir Linux::usermod Locale::gettext Mac::Pasteboard Number::Compare PDF::Burst Perl Perl::OSType Probe::Perl Smart::Comments String::ShellQuote Test::Script Text::Glob Time::Format YAML version cmd? q Roberts-MacBook-Pro:~ rproctor$

      Here is my console:

      Roberts-MacBook-Pro:~ rproctor$ sudo cpanm Image::OCR::Tesseract Password: --> Working on Image::OCR::Tesseract Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/Image-O +CR-Tesseract-1.24.tar.gz ... OK Configuring Image-OCR-Tesseract-1.24 ... OK ==> Found dependencies: LEOCHARRE::CLI --> Working on LEOCHARRE::CLI Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/LEOCHAR +RE-CLI-1.19.tar.gz ... OK Configuring LEOCHARRE-CLI-1.19 ... OK Building and testing LEOCHARRE-CLI-1.19 ... FAIL ! Installing LEOCHARRE::CLI failed. See /Users/rproctor/.cpanm/build.l +og for details. ! Bailing out the installation for Image-OCR-Tesseract-1.24. Retry wit +h --prompt or --force. Roberts-MacBook-Pro:~ rproctor$

      Here is the build.log file

      cpanm (App::cpanminus) 1.4008 on perl 5.012004 built for darwin-thread +-multi-2level Work directory is /Users/rproctor/.cpanm/work/1365523347.84727 You have make /usr/bin/make You have /usr/bin/curl You have /usr/bin/tar: bsdtar 2.8.3 - libarchive 2.8.3 You have /usr/bin/unzip Searching Image::OCR::Tesseract on cpanmetadb ... --> Working on Image::OCR::Tesseract Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/Image-O +CR-Tesseract-1.24.tar.gz -> OK Unpacking Image-OCR-Tesseract-1.24.tar.gz Entering Image-OCR-Tesseract-1.24 Checking configure dependencies from META.yml Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.64) Configuring Image-OCR-Tesseract-1.24 Running Makefile.PL Warning: prerequisite LEOCHARRE::CLI 1.19 not found. Checking if your kit is complete... Looks good Writing Makefile for Image::OCR::Tesseract Writing MYMETA.yml and MYMETA.json -> OK Checking dependencies from MYMETA.yml ... Finding PREREQ from Makefile ... Checking if you have LEOCHARRE::CLI 1.19 ... No Checking if you have File::Find::Rule 0.30 ... Yes (0.33) Checking if you have File::Copy 2.09 ... Yes (2.18) Checking if you have File::Spec 3.29 ... Yes (3.31_01) Checking if you have File::Which 0.05 ... Yes (1.09) Checking if you have Test::Simple 0 ... Yes (0.94) Checking if you have Exporter 5 ... Yes (5.64_01) Checking if you have String::ShellQuote 0 ... Yes (1.04) Checking if you have Carp 1 ... Yes (1.17) Checking if you have File::Path 2.07 ... Yes (2.08_01) Checking if you have Cwd 3 ... Yes (3.31) Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.64) Checking if you have File::Find::Rule 0.30 ... Yes (0.33) Checking if you have File::Copy 2.09 ... Yes (2.18) Checking if you have File::Spec 3.29 ... Yes (3.31_01) Checking if you have File::Which 0.05 ... Yes (1.09) Checking if you have Test::Simple 0 ... Yes (0.94) Checking if you have Exporter 5 ... Yes (5.64_01) Checking if you have String::ShellQuote 0 ... Yes (1.04) Checking if you have Carp 1 ... Yes (1.17) Checking if you have File::Path 2.07 ... Yes (2.08_01) Checking if you have Cwd 3 ... Yes (3.31) ==> Found dependencies: LEOCHARRE::CLI Searching LEOCHARRE::CLI on cpanmetadb ... --> Working on LEOCHARRE::CLI Fetching http://search.cpan.org/CPAN/authors/id/L/LE/LEOCHARRE/LEOCHAR +RE-CLI-1.19.tar.gz -> OK Unpacking LEOCHARRE-CLI-1.19.tar.gz Entering LEOCHARRE-CLI-1.19 Checking configure dependencies from META.yml Configuring LEOCHARRE-CLI-1.19 Running Makefile.PL Checking if your kit is complete... Looks good Writing Makefile for LEOCHARRE::CLI Writing MYMETA.yml and MYMETA.json -> OK Checking dependencies from MYMETA.yml ... Finding PREREQ from Makefile ... Checking if you have YAML 0 ... Yes (0.84) Checking if you have Getopt::Std 0 ... Yes (1.06) Checking if you have File::Which 0 ... Yes (1.09) Checking if you have Linux::usermod 0 ... Yes (0.69) Checking if you have File::chmod 0 ... Yes (0.32) Checking if you have LEOCHARRE::DEBUG 0 ... Yes (1.14) Checking if you have Carp 0 ... Yes (1.17) Checking if you have ExtUtils::MakeMaker 0 ... Yes (6.64) Checking if you have YAML 0 ... Yes (0.84) Checking if you have Getopt::Std 0 ... Yes (1.06) Checking if you have File::Which 0 ... Yes (1.09) Checking if you have Linux::usermod 0 ... Yes (0.69) Checking if you have File::chmod 0 ... Yes (0.32) Checking if you have Carp 0 ... Yes (1.17) Checking if you have LEOCHARRE::DEBUG 0 ... Yes (1.14) Building and testing LEOCHARRE-CLI-1.19 cp lib/LEOCHARRE/CLI.pm blib/lib/LEOCHARRE/CLI.pm Manifying blib/man3/LEOCHARRE::CLI.3pm PERL_DL_NONLAZY=1 /opt/local/bin/perl "-MExtUtils::Command::MM" "-e" " +test_harness(0, 'blib/lib', 'blib/arch')" t/*.t t/0.t, debug sub t/0.t, [/Users/rproctor/.cpanm/work/1365523347.84727/LEOCHARRE-CLI-1.1 +9/t/0.conf] does not exist. at lib/LEOCHARRE/CLI.pm line 283. t/0.t .............. ok t/5_whoami.t ....... ok t/7_tmpdir.t ....... ok No such file or directory at lib/LEOCHARRE/CLI.pm line 69 # Looks like your test exited with 2 just after 3. t/80_usermodetc.t .. Dubious, test returned 2 (wstat 512, 0x200) All 3 subtests passed Test Summary Report ------------------- t/80_usermodetc.t (Wstat: 512 Tests: 3 Failed: 0) Non-zero exit status: 2 Files=4, Tests=22, 0 wallclock secs ( 0.02 usr 0.01 sys + 0.14 cusr + 0.02 csys = 0.19 CPU) Result: FAIL Failed 1/4 test programs. 0/22 subtests failed. make: *** [test_dynamic] Error 2 -> FAIL Installing LEOCHARRE::CLI failed. See /Users/rproctor/.cpanm/b +uild.log for details. -> FAIL Bailing out the installation for Image-OCR-Tesseract-1.24. Ret +ry with --prompt or --force.

      Any suggestions for fixing this problem?

        I used cpan rather than cpanm to install this successfully on Solaris, I don't have access to test this on Linux at the just at the moment, and the only Apple computer I own is 24 years old. Looking at the test matrix it would seem like there are problems building this module on your platform. Investigate the tests which throw legitimate complaints.

        Any suggestions for fixing this problem?

        Satisfy the external dependencies, there is nothing else you can do

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1027719]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (6)
As of 2014-10-20 09:59 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    For retirement, I am banking on:










    Results (75 votes), past polls