Beefy Boxes and Bandwidth Generously Provided by pair Networks Frank
Pathologically Eclectic Rubbish Lister
 
PerlMonks  

Re: Why does this not work? - Can't call method on an undefined value!!!

by graff (Chancellor)
on May 07, 2013 at 02:31 UTC ( #1032428=note: print w/ replies, xml ) Need Help??


in reply to Why does this not work? - Can't call method on an undefined value!!!

VMware is a topic about which I know virtually nothing. But apart from that...

Your code is using modules that don't currently exist on CPAN. Are you using home-grown modules? If so, then you'll have to look more closely at your own local code base for "VMware::VIRuntime" (assuming it's documented), to see whether that helps to figure out what the problem is.

If you're using modules that used to exist on CPAN, then you should probably look for more recent modules that are currently supported (and might do a better job in terms of what you want to get done).

Having just browsed CPAN for "VMware" and related things, I noticed that the "See Also" sections of some modules make reference to other modules (like "VMware::VmPerl") that seem to have gone missing, so this is probably a somewhat volatile domain in terms of CPAN module life-spans.

But maybe the CPAN results for "VmWareESX" might be relevant? (I wouldn't have a clue whether they are or not.)


Comment on Re: Why does this not work? - Can't call method on an undefined value!!!

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1032428]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others perusing the Monastery: (9)
As of 2014-04-23 19:12 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (553 votes), past polls