Beefy Boxes and Bandwidth Generously Provided by pair Networks
There's more than one way to do things
 
PerlMonks  

Re^4: Infuriating Modules Dependency Question

by clegane (Novice)
on Aug 20, 2013 at 21:03 UTC ( #1050245=note: print w/ replies, xml ) Need Help??


in reply to Re^3: Infuriating Modules Dependency Question
in thread Infuriating Modules Dependency Question

CountZero, thanks! I had not seen that. Can it be installed with cpan? This: 'cpan install Crypt::OpenSSL' doesn't seem to work. Sorry, I know I'm probably asking very basic questions.


Comment on Re^4: Infuriating Modules Dependency Question
Re^5: Infuriating Modules Dependency Question
by hippo (Vicar) on Aug 20, 2013 at 21:51 UTC

    OpenSSL is not a perl package, so you cannot use cpan to install it. Just download it from the website, compile and install.

Re^5: Infuriating Modules Dependency Question
by syphilis (Canon) on Aug 21, 2013 at 02:57 UTC
    This: 'cpan install Crypt::OpenSSL' doesn't seem to work

    Looks to me that you're using ActivePerl. There are ppm packages (only for 32-bit perls 5.6, 5.8, 5.10, 5.12, 5.14 and 5.16) at the bribes repo.
    If you have one of those perls, you can install Crypt::SSLeay by running:
    ppm install http://www.bribes.org/perl/ppm/Crypt-SSLeay.ppd
    Tonight I'll build ppm packages for Crypt::SSLeay for the "missing" architectures and put them on the sisyphusion repo.

    Update: Crypt::SSLeay ppm packages now added to the sisyphusion repo.

    Cheers,
    Rob

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1050245]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (12)
As of 2015-07-07 12:30 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (88 votes), past polls