Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re^3: Stop suggesting to upgrade perl

by choroba (Chancellor)
on Aug 31, 2013 at 20:14 UTC( #1051749=note: print w/replies, xml ) Need Help??


in reply to Re^2: Stop suggesting to upgrade perl
in thread Stop suggesting to upgrade perl

Unicode in Perl works mostly fine since 5.8.8.
Except for the "Unicode bug", which was solved a bit later.
لսႽ ᥲᥒ⚪⟊Ⴙᘓᖇ Ꮅᘓᖇ⎱ Ⴙᥲ𝇋ƙᘓᖇ

Replies are listed 'Best First'.
Re^4: Stop suggesting to upgrade perl
by vsespb (Chaplain) on Aug 31, 2013 at 20:42 UTC
    Except for the "Unicode bug", which was solved a bit later.
    Which is not a big problem:

    perlunicode
    For Perls earlier than those described above, or when a string is passed to a function outside the subpragma's scope, a workaround is to always call utf8::upgrade($string)

    Anyway, there is an example of node, where, thankfully, people *did not* suggested me to upgrade perl: Force ASCII regexp for all perls 5.8+ (perhaps because perl version was in post title)

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1051749]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others romping around the Monastery: (1)
As of 2016-08-30 02:50 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    The best thing I ever won in a lottery was:















    Results (410 votes). Check out past polls.