Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

"Message Inbox" is not displaying messages

by kcott (Abbot)
on Mar 07, 2014 at 02:13 UTC ( #1077309=monkdiscuss: print w/ replies, xml ) Need Help??

My Message Inbox is indicating "Inbox (2)" but no messages are displayed.

I can see both messages in the Chatterbox section.

I've tried accessing the Message Inbox via the following links:

  • http://www.perlmonks.org/?node=Message+Inbox;srch_folder=0: the "And 0 more" link in the Chatterbox section.
  • http://www.perlmonks.org/?node=message+inbox: the "... private messages ..." link in Message Settings.
  • http://www.perlmonks.org/?node=Message%20Inbox: the "... Message Inbox ..." link in Message Outbox.

Logging out and back in again didn't fix it.

I also tried logging in to www.perlmonks.net and www.perlmonks.com: no messages were displayed in the Message Inbox using these URLs.

-- Ken

Comment on "Message Inbox" is not displaying messages
Select or Download Code
Re: "Message Inbox" is not displaying messages (options)
by tye (Cardinal) on Mar 07, 2014 at 03:40 UTC

    As I recall, demerphq implemented several bits of persistence for Message Inbox options. That would be my guess as to what is causing you problems. The link with srch_folder=0 should (and does appear to) reset most of these options for that visit.

    But my attempts to narrow down the cause just eliminated all persisted options. But that probably just means I missed something.

    You have an inbox-related setting with a value of "From". I'd expect that to cause the "From" checkbox to be checked and the "To" checkbox to be cleared which would cause the page to display the messages from the adjacently displayed inbox owner (you) instead of those to you.

    But there are also several contraindications against that cause. If "From" is checked, then the number after "Inbox" would be the number of messages from as well. Further, having the "From" checkbox be the default should be ignored when you use the srch_folder=0 link (but maybe that wasn't (properly) implemented). I did not succeed in making that option persistent for me, but I only tried the obvious.

    The observed behavior might be explained by a persisted "offset" into the list of messages. But I would hope that that value could not be persisted. If it were, that would be discernible at the bottom of the (empty) list. I also saw no such persisted option in your options (and they are listed alphabetically and their names are prefixed such that related options are listed together).

    There are also options for which direction to sort messages and at which end to truncate the list. It certainly could be a bug in a particular combination of those options. (I recall at least some confusion involved in some code updates related to those.)

    A solution is likely to be found either in one of the form elements on the Message Inbox page or in one of the overly numerous form elements on User Settings or one of the other settings pages linked at the top of it.

    Perhaps one of the dozens of pmdev members might follow up if that isn't enough for you to be able to find a solution or if, after finding the solution, you believe this is actually due to a bug that should be fixed.

    - tye        

      Thanks for the detailed reply.

      First the good news: I clicked on [constrain] and messages were listed.

      Now some additional details which may help anyone looking into this.

      Throughout all my various attempts at using different links, URLs and logging in and out (detailed in the OP), I made no changes whatsoever to anything in "Message Settings" or "Message Inbox".

      In "Message Settings", I have "/msg me when there's a reply to one of my posts" checked and three folders (Deleted, Inbox and Archive — listed in that order); everything else in either unchecked or blank.

      In "Message Inbox", I have "To kcott" and "Inbox (n)" checked; everything else in either unchecked or blank.

      Prior to clicking [constrain], I had messages in all three folders: Inbox (2); Archive (119); Deleted (3). [Guess: the code behind this part of the site either "saw" all of those as unchecked or "saw" some other combination which generated an empty list (e.g. I just tried "From kcott" and "Deleted", which listed nothing).]

      Any changes I may have made to "Message Settings" would have been years ago; certainly nothing recently.

      I only rarely change the "Message Inbox" settings. I don't recall listing deleted or archived messages recently but may have done.

      I nearly always access "Message Inbox" via the CB link (with srch_folder=0): your comment about this resetting the options sounds about right (but I'm guessing a bit there).

      I use "Message Inbox" frequently (often several times a day) and haven't seen this behaviour previously. I'd consider myself reasonably proficient in its use.

      That's all I can think of that might be helpful: happy to provide more on request.

      -- Ken

Re: "Message Inbox" is not displaying messages
by LanX (Canon) on Mar 07, 2014 at 03:57 UTC
    The user-interface of message inbox is somehow overloaded and confusing.

    Are you sure you've selected "To kcott" and "Inbox" in the top rows?

    Cheers Rolf

    ( addicted to the Perl Programming Language)

      Thanks for responding. Yes, I had those selected. My reply to tye (above) has more complete details.

      -- Ken

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: monkdiscuss [id://1077309]
Approved by Athanasius
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (6)
As of 2014-08-23 08:26 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (172 votes), past polls