Beefy Boxes and Bandwidth Generously Provided by pair Networks
The stupid question is the question not asked
 
PerlMonks  

System command on servers

by AndreaN (Novice)
on Jun 17, 2014 at 22:57 UTC ( #1090223=perlquestion: print w/ replies, xml ) Need Help??
AndreaN has asked for the wisdom of the Perl Monks concerning the following question:

Dear Monks, I have a script in which I use system ("command") to launch a Java application that is in the same folder of the script. Something like:
$command = "java -mx300m -classpath application_name.jar -model path" +; system("$command");
When used on my machine this works fine. Now I'm trying to run the same code from a cgi folder on a server. When I run the same script as a cgi script on the server everything works fine except for the system ("$command") part. It seems like I cannot run that Java application from the server. Or perhaps servers do not accept the "system" function at all? Or perhaps I cannot have a .jar file in the cgi folder? Does anybody know something that can help me diagnose the problem? I apologise in advance if any of this does not make sense. I have never received formal training in programming or computer science and I'm just learning by doing. Thanks a lot.

Comment on System command on servers
Select or Download Code
Re: System command on servers
by Anonymous Monk on Jun 18, 2014 at 00:04 UTC
Re: System command on servers
by Corion (Pope) on Jun 18, 2014 at 06:52 UTC

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1090223]
Approved by Old_Gray_Bear
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others meditating upon the Monastery: (4)
As of 2015-07-05 14:13 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (67 votes), past polls