Beefy Boxes and Bandwidth Generously Provided by pair Networks
laziness, impatience, and hubris
 
PerlMonks  

Re: Why doesn't file upload work under NT?

by guice (Scribe)
on May 16, 2000 at 01:27 UTC ( #11752=note: print w/ replies, xml ) Need Help??


in reply to Why doesn't file upload work under NT?

Hum.. Sounds like possibly Line Breaks as well. After all .pdf files are just text files. Although if there are some images in there, that may cause in issue. Make sure that you are setting your like breaks correctly as well. On the Windows OS its: \r\n and on Unix/Linux its: \n. It's \r on Macintosh systems incause you're curious :)
If there are no images in the PDF file, then you are fine. If there are, then make sure you use binmode. It sounds like binmode isn't an issue cause it works on your linux system. The next thing is to play with your line breaks. Set $\ to "\r\n" on the windows system and "\n" on the linux system (Perl defaults to "\n"). Better yet, take a look at the file on the WinNT box. You may have \n in there, so you just need to convert "\n" to "\r\n" to get it working.

A couple things for ya to try out ;)

-- philip
We put the 'K' in kwality!


Comment on Re: Why doesn't file upload work under NT?
Re: Re: Why doesn't file upload work under NT?
by Chris2323 on Apr 21, 2001 at 03:51 UTC
    I have the same problem on win32! No cigar as yet

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://11752]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others studying the Monastery: (6)
As of 2014-09-17 06:48 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    How do you remember the number of days in each month?











    Results (61 votes), past polls