Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

Perlbrew mismatched error

by LunarCowgirl (Sexton)
on Apr 17, 2017 at 20:07 UTC ( #1188157=perlquestion: print w/replies, xml ) Need Help??
LunarCowgirl has asked for the wisdom of the Perl Monks concerning the following question:

The perlbrew on my current machine was using Perl 5.22.0, so I had it install the latest Perl, 5.24.1. The install was successful, and Perl seems to work fine. Perlbrew however doesn't want to work properly with the 5.24.1 it installed. I can do basic things like switch versions, but if I run list-modules or try to use cpanm or cpan to install anything, I get the following error:

Encode.c: loadable library and perl binaries are mismatched (got handshake key 0xd700000, needed 0xd600000)

I tried uninstalling 5.24.1 and then installing it again, but the same thing happens. Everything works fine with perlbrew under 5.22.0. Any clues as to why perlbrew won't work on this 5.24.1? Google has not been helpful.

Replies are listed 'Best First'.
Re: Perlbrew mismatched error
by ikegami (Pope) on Apr 18, 2017 at 19:19 UTC

    These shouldn't be in @INC:

    /home/autumn/perl5/lib/perl5/x86_64-linux /home/autumn/perl5/lib/perl5

    Do you have PERL5LIB or PERLLIB set?

Re: Perlbrew mismatched error
by LunarCowgirl (Sexton) on Apr 18, 2017 at 22:05 UTC
    All right! Got it working. Thanks to everyone for the hints and help. PERL5LIB was indeed being set. I finally found where that was and unset it, and perlbrew now installs modules in each separate Perl version instead of in the monolithic lib/perl5 folder.
      "...PERL5LIB was indeed being set..."

      For curiosity: Do you remember where and why you set it?

      Thanks and regards, Karl

      «The Crux of the Biscuit is the Apostrophe»

      Furthermore I consider that Donald Trump must be impeached as soon as possible

Re: Perlbrew mismatched error
by Anonymous Monk on Apr 17, 2017 at 21:09 UTC
    So apparently it tries to load Encode compiled with different version of perl. What's the output of perlbrew info and perl -E 'say for @INC'?
      For 5.22.0:
      perlbrew info Current perl: Name: perl-5.22.0 Path: /home/autumn/perl5/perlbrew/perls/perl-5.22.0/bin/perl Config: -de -Dprefix=/home/autumn/perl5/perlbrew/perls/perl-5.22.0 - +Aeval:scriptdir=/home/autumn/perl5/perlbrew/perls/perl-5.22.0/bin Compiled at: Dec 1 2015 17:22:55 perlbrew: version: 0.78 ENV: PERLBREW_ROOT: /home/autumn/perl5/perlbrew PERLBREW_HOME: /home/autumn/.perlbrew PERLBREW_PATH: /home/autumn/perl5/perlbrew/bin:/home/autumn/perl5/ +perlbrew/perls/perl-5.22.0/bin PERLBREW_MANPATH: /home/autumn/perl5/perlbrew/perls/perl-5.22.0/ma +n perl -E 'say for @INC' /home/autumn/perl5/lib/perl5/x86_64-linux /home/autumn/perl5/lib/perl5 /home/autumn/perl5/perlbrew/perls/perl-5.22.0/lib/site_perl/5.22.0/x86 +_64-linux /home/autumn/perl5/perlbrew/perls/perl-5.22.0/lib/site_perl/5.22.0 /home/autumn/perl5/perlbrew/perls/perl-5.22.0/lib/5.22.0/x86_64-linux /home/autumn/perl5/perlbrew/perls/perl-5.22.0/lib/5.22.0 .
      For 5.24.1:
      perlbrew info Current perl: Name: perl-5.24.1 Path: /home/autumn/perl5/perlbrew/perls/perl-5.24.1/bin/perl Config: -de -Dprefix=/home/autumn/perl5/perlbrew/perls/perl-5.24.1 - +Aeval:scriptdir=/home/autumn/perl5/perlbrew/perls/perl-5.24.1/bin Compiled at: Apr 17 2017 12:09:32 perlbrew: version: 0.78 ENV: PERLBREW_ROOT: /home/autumn/perl5/perlbrew PERLBREW_HOME: /home/autumn/.perlbrew PERLBREW_PATH: /home/autumn/perl5/perlbrew/bin:/home/autumn/perl5/ +perlbrew/perls/perl-5.24.1/bin PERLBREW_MANPATH: /home/autumn/perl5/perlbrew/perls/perl-5.24.1/ma +n perl -E 'say for @INC' /home/autumn/perl5/lib/perl5/x86_64-linux /home/autumn/perl5/lib/perl5 /home/autumn/perl5/perlbrew/perls/perl-5.24.1/lib/site_perl/5.24.1/x86 +_64-linux /home/autumn/perl5/perlbrew/perls/perl-5.24.1/lib/site_perl/5.24.1 /home/autumn/perl5/perlbrew/perls/perl-5.24.1/lib/5.24.1/x86_64-linux /home/autumn/perl5/perlbrew/perls/perl-5.24.1/lib/5.24.1 .
      Output seems similar for both versions.
        Being on Windows, I don't have perlbrew, but my guess is the two .../perl5/lib/perl5 entries in @INC should be after the version specific ones. Or omitted, if they stem from the system perl.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://1188157]
Approved by 1nickt
Front-paged by 1nickt
help
Chatterbox?
and all is quiet...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (6)
As of 2017-06-25 12:38 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    How many monitors do you use while coding?















    Results (567 votes). Check out past polls.