Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re: Unable to install OpenGL::Shader

by Corion (Pope)
on Jul 29, 2017 at 08:15 UTC ( #1196262=note: print w/replies, xml ) Need Help??


in reply to Unable to install OpenGL::Shader

This is most likely because OpenGL shaders moved on a bit and now every shader program requires a #version directive at the start.

You could add the appropriate line to the test shader, as discussed in this test report.

A somewhat more recent version of OpenGL bindings is OpenGL::Modern, which also tries to be compatible to OpenGL and OpenGL::Shader, so maybe you want to try that if you want to do shader oriented programming.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1196262]
help
Chatterbox?
and all is quiet...

How do I use this? | Other CB clients
Other Users?
Others drinking their drinks and smoking their pipes about the Monastery: (4)
As of 2017-10-17 01:08 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    My fridge is mostly full of:

















    Results (218 votes). Check out past polls.

    Notices?