Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl-Sensitive Sunglasses

Re: Issue with ssh to a cisco smart switch

by VinsWorldcom (Parson)
on Sep 12, 2017 at 22:43 UTC ( #1199239=note: print w/replies, xml ) Need Help??

in reply to Issue with ssh to a cisco smart switch

Assuming the sg300 does user / password authentication and that's what you're using when you login directly - not public key correct? I don't believe I've enabled public key authentication in Net::SSH2::Cisco - looks like version 0.05 is needed :-)

Also, looks like you enabled Net::SSH2 debugging and the issue is happening before login. You may try 'dump_log' and provide a file name in the new() call, but that will only show data once you're logged in (which looks like you can't).

I had a bit of a different issue described here with fix

  • Comment on Re: Issue with ssh to a cisco smart switch

Replies are listed 'Best First'.
Re^2: Issue with ssh to a cisco smart switch
by edimusrex (Monk) on Sep 13, 2017 at 14:12 UTC

    I'll give that a go and see what happens. I might also try this module on a RHEL server and see if I get the same error, beginning to wonder if it's OS specific. I am not using keystores to log in, just a simple ssh to the switch from the command line.


Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1199239]
and all is quiet...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (7)
As of 2018-03-23 09:06 GMT
Find Nodes?
    Voting Booth?
    When I think of a mole I think of:

    Results (289 votes). Check out past polls.