Beefy Boxes and Bandwidth Generously Provided by pair Networks
Pathologically Eclectic Rubbish Lister
 
PerlMonks  

Re: Playing sounds

by 1nickt (Monsignor)
on Nov 09, 2017 at 17:07 UTC ( #1203069=note: print w/replies, xml ) Need Help??


in reply to Playing sounds

Hi,

$player = Audio::Play::MPG123->new;
gives an error I don't understand:
open3: exec of mpg123 -R --aggressive failed

That shows that the perl wrapper Audio::Play::MPG123 is attempting to launch the system binary mpg123 and failing. Dollars gets you donuts it's because you don't have it installed.

On my Linux the command is:

$ sudo apt-get install mpg123 libmpg123-dev
... you'll have to find the equivalent for MacPorts or whatever package manger you are using.

When you read the docs for a module and it says something like:

"This is a frontend to the mpg123 player. It works by starting an external mpg123 process with the -R option and feeding commands to it."
... it's pretty likely that you'll need a system application.

Hope this helps!


The way forward always starts with a minimal test.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://1203069]
help
Chatterbox?
and all is quiet...

How do I use this? | Other CB clients
Other Users?
Others scrutinizing the Monastery: (5)
As of 2017-12-18 18:50 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    What programming language do you hate the most?




















    Results (495 votes). Check out past polls.

    Notices?