Ironic. While offering me advice on how to avoid having
any ambiguous names, you have hit on a horribly ambiguous
name that I would never leave in code.
One of the most common programming errors - and a hard one
to see - is to reverse the meaning of a flag. For that
reason I consider any flag horribly misnamed unless the
name is a yes/no question which its value is an answer to.
For instance your flag might be appropriately named
$will_create. Do that and you will stop
making that particular mistake again.