in reply to
Funniest Variable/Subroutine names
At University one of my dorm mates was doing a PASCAL course and was told off for using variables like 'a' and 'b' in his programming assessments and was told to produce more descriptive names in the next assessment. So he started using 'this_variable_is_the_loop_counter_it_counts_the_loops' and 'i_am_storing_the_number_of_times_that_the_user_has_responded_with_a_yes_here'
the instructor stopped hassling him after that :-}
---If it doesn't fit use a bigger hammer