Beefy Boxes and Bandwidth Generously Provided by pair Networks
"be consistent"
 
PerlMonks  

Re: %20

by krujos (Curate)
on May 20, 2002 at 19:28 UTC ( #167920=note: print w/ replies, xml ) Need Help??


in reply to %20
in thread backtick ignores parameters

A, Sorry if this sounds mean, I dont intend to be, but did you try it?
B, I went back and checked out some old scripts. I had this problem as well a long time ago. I ended up using a question mark to between the params and that worked. I am not sure why exactly (darn this getting old thing). If any monks have some insight to the question mark thing I would be grateful.
let this be a lesson to me to comment code better.

update changed formatting...
also, when you run things from the command line, the shell translates it first. I dont think it works the same way from inside the script. Agian please correct me if I am wrong.
Thanks Josh


Comment on Re: %20
Re: %20
by unclepliny (Initiate) on May 20, 2002 at 19:40 UTC
    Actually I did try after all :) , just to cover all angles -- tried every variation (with and without ?, with and without &, etc). No luck. You are apparently right about it working differently from within a CGI script ... (see responses below).

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://167920]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others examining the Monastery: (8)
As of 2014-12-26 07:38 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    Is guessing a good strategy for surviving in the IT business?





    Results (168 votes), past polls