Beefy Boxes and Bandwidth Generously Provided by pair Networks
Your skill will accomplish
what the force of many cannot
 
PerlMonks  

Re: Re: Re: Error using HTML::Template

by jsprat (Curate)
on Dec 11, 2003 at 20:49 UTC ( #314158=note: print w/ replies, xml ) Need Help??


in reply to Re: Re: Error using HTML::Template
in thread Error using HTML::Template

My remote server is Tripod
There's your problem. Tripod severely crippled Perl when they upgraded to 5.8. Not even the standard modules are available. I wouldn't recommend Tripod to anyone.

Try this minimal script:

print "Content-Type: text/plain\n\n"; print "\@INC is:"; print join ":", @INC;

It's empty! Bad Tripod!

Here's another one to try, even more minimal:

use strict;

And the resulting error message1:

Your script produced this error: Can't locate strict.pm in @INC (@INC contains: . /lib /site_perl) at n +ostrict.pl line 1. BEGIN failed--compilation aborted at nostrict.pl line 1.

I tried to manually satisfy the requirements for a simple site for a friend, and ended up giving up on Tripod all together (I still remember the login info ;).

1Note - in the second error message, @INC is populated. Not sure why...


Comment on Re: Re: Re: Error using HTML::Template
Select or Download Code
Re: Re: Re: Re: Error using HTML::Template
by Anneq (Vicar) on Dec 12, 2003 at 03:45 UTC

    isprat,

    Actually Tripod had been great for me up until this point. You can solve the above error by uploading the strict module to "/cgi-bin" in your friend's directory. The @INC error has been helpful to me in that it tells me what module I'm missing, and then I upload it. Try it again for your friend and I think you'll find that it works fine.

    Actually, I'm using the free web hosting option on Tripod and was pleasantly suprised to learn that it lets me use Perl scripts. My regular ISP, which I pay for, doesn' give me this capability. Tripod's servers don't appear to be slow at any time and they respond to requests for help extremely rapidly, even for free users.

    Thanks,

    Anne

    Anneq
      I did the same thing - that's what I meant by "manually satisfy the requirements". I gave up on Cwd, since it uses xs.

      Let me try something...

      Try this, it works for me. Rename the real Cwd.pm and upload a 'new' Cwd.pm, with the following:

      package Cwd; require Exporter; use vars @EXPORT; @EXPORT = qw/getcwd/; sub import { my $pkg = shift; my $caller = caller; Exporter::export( $pkg, $caller, @EXPORT ); } sub getcwd { '.' } 1;

      Here are the rest of the modules you'll need:

      Once you've uploaded all of these, try running the code from HTML::Template's pod.

      Good luck!

        jsprat,

        Excellent! It worked. Now I need to go away for a while and find out why.

        Many thanks for your help,

        Anne

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://314158]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others about the Monastery: (13)
As of 2014-10-01 13:48 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    What is your favourite meta-syntactic variable name?














    Results (21 votes), past polls