Since I am using these subroutines to return arrays and hashes, they do not benefit from being made into something which looks like an object. I should rename the module to Twitter::Data, take out all of the $class variables and bless uses, and change the calls to it from Twitter::Objects->subName; to Twitter::Data::subName;. The module will still be useful since I will not have to copy and paste the same arrays and hashes in the thirty-odd scripts I have written using the data. Thank you for helping me see where I went wrong in my thinking.
Have a cookie and a very nice day!
Posts are HTML formatted. Put <p> </p> tags around your paragraphs. Put <code> </code> tags around your code and data!
Titles consisting of a single word are discouraged, and in most cases are disallowed outright.
Read Where should I post X? if you're not absolutely sure you're posting in the right place.
Please read these before you post! —
Posts may use any of the Perl Monks Approved HTML tags:
You may need to use entities for some characters, as follows. (Exception: Within code tags, you can put the characters literally.)
- a, abbr, b, big, blockquote, br, caption, center, col, colgroup, dd, del, div, dl, dt, em, font, h1, h2, h3, h4, h5, h6, hr, i, ins, li, ol, p, pre, readmore, small, span, spoiler, strike, strong, sub, sup, table, tbody, td, tfoot, th, thead, tr, tt, u, ul, wbr
Link using PerlMonks shortcuts! What shortcuts can I use for linking?
See Writeup Formatting Tips and other pages linked from there for more info.
| & || & |
| < || < |
| > || > |
| [ || [ |
| ] || ] ||