Beefy Boxes and Bandwidth Generously Provided by pair Networks
Just another Perl shrine
 
PerlMonks  

Re: "use" acting like "require" (not importing????)

by Wonko the sane (Deacon)
on Mar 09, 2004 at 19:20 UTC ( #335244=note: print w/ replies, xml ) Need Help??


in reply to "use" acting like "require" (not importing????)

Hello,

The param method is not exported by Default. You must request it.

Try:

use CGI qw( :all ); # Import Everything

Wonko


Comment on Re: "use" acting like "require" (not importing????)
Download Code
Re: Re: "use" acting like "require" (not importing????)
by woozy (Novice) on Mar 09, 2004 at 19:46 UTC
    Thanks. (:all) fixed it (and I assume (:cgi) would too) so thanks to you all.

Re: Re: "use" acting like "require" (not importing????)
by muba (Priest) on Mar 09, 2004 at 22:40 UTC
    I'm not sure, but I think I can remember I've learned to use 'use CGI qw( :standard );'
    
    my $native_language = "Dutch";
    my $code = !$tested unless defined $otherwise;
    

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://335244]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (3)
As of 2015-07-04 23:09 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (60 votes), past polls