Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery
 
PerlMonks  

Re: Re: Re: Setting up Perl/CGI with Windows

by strat (Canon)
on Mar 11, 2004 at 09:27 UTC ( #335750=note: print w/replies, xml ) Need Help??


in reply to Re: Re: Setting up Perl/CGI with Windows
in thread Setting up Perl/CGI with Windows

Either you don't send a content-type, or you don't send it as the first output. Does the following code work?
#! /usr/bin/perl use warnings; use strict; use CGI; use CGI::Carp qw(fatalsToBrowser warningsToBrowser); my $cgi = CGI->new(); print $cgi->header(), $cgi->start_html('Testpage'); print $cgi->h1('Testpage'); print $cgi->end_html();

Best regards,
perl -e "s>>*F>e=>y)\*martinF)stronat)=>print,print v8.8.8.32.11.32"

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://335750]
help
Chatterbox?
[marto]: yes, not reading the errors displayed has been a cause of this type of report in the past
[nysus]: Ambrus, ah. I think that was the problem. I'll try. Thanks!
[davies]: Ambrus: you've missed it by a couple of weeks, but consider next year's London Perl Workshop.

How do I use this? | Other CB clients
Other Users?
Others avoiding work at the Monastery: (5)
As of 2017-12-15 11:37 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    What programming language do you hate the most?




















    Results (431 votes). Check out past polls.

    Notices?