Beefy Boxes and Bandwidth Generously Provided by pair Networks
P is for Practical
 
PerlMonks  

Re: CGI-Attachment with many \0's

by matija (Priest)
on May 06, 2004 at 13:54 UTC ( #351113=note: print w/ replies, xml ) Need Help??


in reply to CGI-Attachment with many \0's

Are you using binmode when writing the files?

Are the local settings the same on both machines? (As soon as you mention RedHat, I think of locale problems).


Comment on Re: CGI-Attachment with many \0's
Re: Re: CGI-Attachment with many \0's
by stefan k (Curate) on May 06, 2004 at 13:59 UTC
    Hi,

    Are you using binmode when writing the files?

    No, I thought that were only important when dealing with different platforms. And it ran fine on the Windowsmachine and with Windowsclients.

    Are the local settings the same on both machines? (As soon as you mention RedHat, I think of locale problems).

    And how much I fought with them! They made me XEmacs broken, but that's another story. The locale setting differs: the good box has

    LANG="en_US.iso88591" SYSFONT="latarcyrheb-sun16"
    the bad box has
    LANG="en_US" SUPPORTED="en_US" SYSFONT="latarcyrheb-sun16"
    Can _that_ be a problem??

    Regards... Stefan
    you begin bashing the string with a +42 regexp of confusion

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://351113]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (13)
As of 2014-07-14 12:34 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    When choosing user names for websites, I prefer to use:








    Results (259 votes), past polls