Beefy Boxes and Bandwidth Generously Provided by pair Networks
We don't bite newbies here... much
 
PerlMonks  

Re: While loop not exiting when expected.

by Hofmator (Curate)
on Jun 25, 2004 at 10:07 UTC ( #369586=note: print w/ replies, xml ) Need Help??


in reply to While loop not exiting when expected.

I can't reproduce your problem with the code given. The last output of your program goes like this:

11733 started. Got arguments: i2 j2 11734 started. Got arguments: k2 l2 11735 started. Got arguments: m2 n2 11736 started. Got arguments: o2 p2 11737 started. Got arguments: q2 r2 Foobar! Foobar! Foobar! Foobar! Foobar! 11737 returned 0. 11734 returned 0. 11736 returned 0. 11735 returned 0. 11733 returned 0. 11738 started. Got arguments: s2 t2 11739 started. Got arguments: u2 v2 11740 started. Got arguments: w2 y2 11741 started. Got arguments: x2 z2 Foobar! Foobar! Foobar! Foobar!
and then it terminates as expected.

I'm on v5.8.0 built for i586-linux-thread-multi.

-- Hofmator


Comment on Re: While loop not exiting when expected.
Download Code
Re^2: While loop not exiting when expected.
by BazB (Priest) on Jun 25, 2004 at 19:02 UTC

    The code appears to work OK under v5.8.3 built for i386-linux-thread-multi, but it failed under v5.8.4 built for sun4-solaris.

    It looks like there's some kind of wierdness only on Solaris.


    If the information in this post is inaccurate, or just plain wrong, don't just downvote - please post explaining what's wrong.
    That way everyone learns.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://369586]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others examining the Monastery: (12)
As of 2015-07-06 21:16 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (83 votes), past polls