in reply to
The Secretary wants to Make LWP Requests too...
in thread Apparent Inconsistencies in Perl Function Naming
Programming is the practice of converting human thought to computer syntax. Programming has seen an evolution from punched cards, to machine language, to
assembler language, to C and to Perl. In each case, the language has moved further from "speaking to the CPU" to "here's what I want to do."
I'm going to weigh in with heavy support for this statement. One of the great things about Perl is that Larry questioned some of the assumptions other languages made, and thus moved the line between DWIM and DWIS closer to DWIM. There has to be a limit somewhere though, which is why I also disagree with the initial post.
As has been mentioned, there's always been a faction that dislikes the can-be-misleading name of length(). This is the first time I've ever heard a complaint about array slices, and I can't say I agree with that complaint.
The approach to take is not "This is wrong" but "how can I make this right in all cases". Length,as has been mentioned, shouldn't be too hard to change with no real loss. If you can come up with new examples where a "commoner" would think something, and a fix that doesn't break the flow of a long-term programmer, detail it. Submit a proposal to the Perl maintainers, write a patch, or whatever.