Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re: UTF 8 character not displaying after PERL script

by dakkar (Hermit)
on Mar 23, 2005 at 15:10 UTC ( #441790=note: print w/ replies, xml ) Need Help??


in reply to UTF 8 character not displaying after PERL script

It's a bug in IE. There is (was?) a similar bug in Safari. What happens is that the browser does not re-parse all the information it has on the page when loading it from the cache, and so it creates the form control in a different way than the first time. What it boils down to is exactly what you see: you put some non-ASCII character in a field, submit, back, and your characters are mangled or gone. There is nothing you can do to fix it, you can only work around it.

I'd second the suggestion of giving the error together with the form, pre-filled with the submitted values.

-- 
        dakkar - Mobilis in mobile

Most of my code is tested...

Perl is strongly typed, it just has very few types (Dan)


Comment on Re: UTF 8 character not displaying after PERL script

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://441790]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (15)
As of 2014-07-23 17:31 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My favorite superfluous repetitious redundant duplicative phrase is:









    Results (148 votes), past polls