Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Unknown arguments to Tap::Harness::new when installing/upgrading perl modules

by jfroebe (Parson)
on Feb 06, 2008 at 03:30 UTC ( #666453=perlquestion: print w/ replies, xml ) Need Help??
jfroebe has asked for the wisdom of the Perl Monks concerning the following question:

Perl v5.8.8 built for x86_64-linux-gnu-thread-multi on Centos 5.

I've performed a force install Test::Harness which completes with no errors. Has anyone else run into this?

ADAMK/Archive-Zip-1.23.tar.gz /usr/bin/make -j5 -j5 -- OK Running make test PERL_DL_NONLAZY=1 /usr/bin/perl "-MExtUtils::Command::MM" "-e" "test_h +arness(0, 'blib/lib', 'blib/arch')" t/*.t Unknown arguments to TAP::Harness::new (verbosity color) at /usr/lib/p +erl5/5.8.8/Test/Harness.pm line 271 make: *** [test_dynamic] Error 9 ADAMK/Archive-Zip-1.23.tar.gz /usr/bin/make test -- NOT OK

update: I copied the /usr/lib/perl5 from another server to workaround the problem.

Jason L. Froebe

Blog, Tech Blog

Comment on Unknown arguments to Tap::Harness::new when installing/upgrading perl modules
Download Code
Replies are listed 'Best First'.
Re: Unknown arguments to Tap::Harness::new when installing/upgrading perl modules
by chrisdolan (Beadle) on Mar 08, 2008 at 19:20 UTC
    I had the same problem and Andy Armstrong solved it for me: I had mismatched Test::Harness vs. TAP::Harness installed. Removing the older one fixed it.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://666453]
Approved by kyle
Front-paged by grinder
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (12)
As of 2015-07-28 21:49 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (259 votes), past polls