Beefy Boxes and Bandwidth Generously Provided by pair Networks BBQ
Welcome to the Monastery
 
PerlMonks  

Re: The execution of my CGI opens a new navigator window

by Corion (Pope)
on Mar 06, 2008 at 16:51 UTC ( #672497=note: print w/ replies, xml ) Need Help??


in reply to The execution of my CGI opens a new navigator window

As I told you two times in the Chatterbox already, this is a problem with the HTML from which you are linking to your CGI, and not within your CGI. So it behooves you to inspect the HTML linking to your CGI.


Comment on Re: The execution of my CGI opens a new navigator window
Re^2: The execution of my CGI opens a new navigator window
by ofornes (Novice) on Mar 06, 2008 at 17:03 UTC
    Following corions advice I checked my index.html (where I call my CGI) and found the following in the head:
    <base href="http://localhost/" target="_blank" />
    This seems to be the problem. I don't know what this is doing here, maybe I did a copypaste from the CGI header output to my index page without knowledge V_v'
    I am sorry for all the inconveniences I have created to you all and thank you very much.
      Given your poor description of the problem, I think the lesson here is to debug your HTML code before saying that "execution of my CGI opens a new navigator window", especially when the fist example you give us does not exhibit this behaviour. Check out firebug if you have not already done so.

      Martin

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://672497]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others drinking their drinks and smoking their pipes about the Monastery: (12)
As of 2014-04-24 12:37 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (565 votes), past polls