Beefy Boxes and Bandwidth Generously Provided by pair Networks
Your skill will accomplish
what the force of many cannot

Re^6: Math::Pari patch for 5.10.0

by syphilis (Chancellor)
on Mar 11, 2008 at 00:50 UTC ( #673388=note: print w/replies, xml ) Need Help??

in reply to Re^5: Math::Pari patch for 5.10.0
in thread Math::Pari patch for 5.10.0

Blead throws up a number of issues that I'll be taking a look at as time permits. (I don't have a lot of time right at the moment ... work is interfering again.)

Firstly, when running the 5.11.0 test suite, op/alarm.t hangs, and killing the hang aborts the test procedure entirely - so I only got to run a small number of the test files.

After installing 5.11.0, I couldn't even get the 'Makefile.PL' step of the Math-Pari build process to complete. It hangs at "...I will use assembler build of type 'ix86'". Killing the hang kills the entire process, so no makefile even gets written.

While I'm at work tonight I'll try it out on my XP laptop. (I'm using Vista here at home.) Interesting ....

Update: On my Windows XP box I get essentially the same error as you reported with Math::Pari.

With 5.10.0 (but not 5.11.0) t/55_objets.t doesn't produce any problems when run as perl -Mblib t/55_objets.t. But when run as part of the 'make test' process (with both 5.10.0 and 5.11.0) I get a segfault during cleanup, when the script is about to exit after all of the tests have been successfully run. Strange that it doesn't affect Vista the same way.

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://673388]
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (9)
As of 2016-10-25 11:10 GMT
Find Nodes?
    Voting Booth?
    How many different varieties (color, size, etc) of socks do you have in your sock drawer?

    Results (317 votes). Check out past polls.