Beefy Boxes and Bandwidth Generously Provided by pair Networks vroom
Syntactic Confectionery Delight
 
PerlMonks  

Re^2: DBI error under mod_perl

by mboudreau (Novice)
on Feb 07, 2009 at 04:16 UTC ( #742079=note: print w/ replies, xml ) Need Help??


in reply to Re: DBI error under mod_perl
in thread DBI error under mod_perl

While running 'make test' on mod_perl, I got test failures accompanied by more error messages about the missing DBI/connect.al. So I reinstalled DBI from scratch, restarted Apache, and now everything works. I could have sworn there were no errors when I reinstalled DBI prior to recompiling mod_perl, but perhaps I missed something.

What puzzles me is that, now that things are working, I still don't find 'connect.al' anywhere on my computer, though apparently Perl has stopped asking for it. What should I learn from that?


Comment on Re^2: DBI error under mod_perl
Re^3: DBI error under mod_perl
by Herkum (Parson) on Feb 07, 2009 at 14:29 UTC

    My guess is that DBI could not use the database driver you had in your connection string so attempted to use a generic driver.

Re^3: DBI error under mod_perl
by perrin (Chancellor) on Feb 07, 2009 at 16:46 UTC
    Ok, I guess your DBI was not compiled against the same perl as mod_perl. This can happen if Apple updates the system perl. On a production system, you either have to avoid system updates that will update perl or just install a separate perl for your use and leave the system one to Apple.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://742079]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others making s'mores by the fire in the courtyard of the Monastery: (4)
As of 2014-04-19 02:15 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    April first is:







    Results (475 votes), past polls