Beefy Boxes and Bandwidth Generously Provided by pair Networks
laziness, impatience, and hubris
 
PerlMonks  

Perl 5.10 cpan shell upgrade and newer versions in perl 5.8.9

by tomfahle (Priest)
on Jun 01, 2009 at 10:58 UTC ( #767224=perlquestion: print w/ replies, xml ) Need Help??
tomfahle has asked for the wisdom of the Perl Monks concerning the following question:

Fellow monks,

I've installed Perl 5.10 from source to /opt/perl510/ on a Linux (Kernel 2.6.24-24) system and a couple of CPAN-Modules via /opt/perl510/bin/cpan to /opt/perl510/lib/.

Now I try to upgrade all modules with CPAN.pm version 1.94:

# /opt/perl510/bin/cpan .... cpan[1]> upgrade CPAN: Storable loaded ok (v2.20) CPAN: YAML loaded ok (v0.68) .... Package namespace installed latest in CPAN file B 1.17 1.19 NWCLARK/perl-5.8.9.tar. +gz .... Running install for module 'File::Copy' The most recent version "2.13" of the module "File::Copy" is part of the perl-5.8.9 distribution. To install that, you need to r +un force install File::Copy --or-- install N/NW/NWCLARK/perl-5.8.9.tar.gz
  • Why is the newest version of e.g. File::Copy in 5.8.9 and not in 5.10?
  • Is there a way to get rid of these calls to perl-5.8.9?

 

Comment on Perl 5.10 cpan shell upgrade and newer versions in perl 5.8.9
Download Code
Re: Perl 5.10 cpan shell upgrade and newer versions in perl 5.8.9
by Bloodnok (Vicar) on Jun 01, 2009 at 11:22 UTC
    To answer your first question, 5.8 and 5.10 represent 2 disparate development streams with individual baselined contents and release roadmap i.e. upgrade & maintenance releases will be made from each stream independently and since both are still live, you cannot infer that 5.8.9 was released before 5.10 (or even 5.10.x), nor can you infer the likely contents of the releases relative to each other...

    I have no doubt that other, better informed, monks will be able to provide further details e.g. links etc., wrt your 1st question </ignorance>

    In (an attempt to) answer your 2nd question, have you tried just simply force upgrade ? AFAICT i.e. I've never tried it, I'd have thought that should force an update to all out-of-date packages.

    A user level that continues to overstate my experience :-))
Re: Perl 5.10 cpan shell upgrade and newer versions in perl 5.8.9
by Anonymous Monk on Jun 01, 2009 at 11:37 UTC

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://767224]
Approved by Perlbotics
Front-paged by Corion
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (10)
As of 2014-08-27 09:27 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (235 votes), past polls