Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Re^2: fastcgi broke my Exports

by perrin (Chancellor)
on Jul 13, 2009 at 21:06 UTC ( #779754=note: print w/replies, xml ) Need Help??


in reply to Re: fastcgi broke my Exports
in thread fastcgi did NOT break my Exports, issue now resolved

There's no reason this should interfere with existing CGI code if you run them on separate virtualhosts. If you comment this out, do your scripts start working again?

Replies are listed 'Best First'.
Re: fastcgi broke my Exports
by hesco (Deacon) on Jul 13, 2009 at 23:19 UTC
    No, it does not. I still get those same errors:Can't locate object method "_GenerateAccountSummary" via package , even though that is a valid method in my ::Account module, use'd by my base class.

    It was a long weekend, but as I ponder this, more of it is coming back to me.

    I'm working on a Debian server. The previous weekend I had installed mod_perl, until I encountered namespace clashes when I attempted to run a second instance of RT on the same apache. Further research led me to believe that fastcgi would bypass that issue.

    But when it came time to install fastcgi, I ran into some conflicts with respect to the pre-requisites. In order to resolve those, I wound up doing an `apt-get dist-upgrade`. I then had to completely rebuild my site's perl lib, most of it from cpan.

    I was focused on making RT work. I did not come back to testing this application under development until I had those two RT instances up and running. And that is when I encountered this issue.

    I don't know if that sheds any light on this situation or not. But perhaps it was not fastcgi which broke Exporter, but something else I did in that move from Etch to Lenny, in order to get fastcgi working.

    I'm baffled, here.

    -- Hugh

    if( $lal && $lol ) { $life++; }
      I can't say where it got broken, but I think it's unrelated to FastCGI. And yes, you can run separate FastCGI backends with different code. It works about the same as it would for mod_perl, i.e. you run two separate backends with different @INCs and point two virtual hosts at them.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://779754]
help
Chatterbox?
[ambrus]: huh... what does "SV" mean there?
[Marshall]: stevieb wish you well with water problems, my water was off all day Monday for repairs. Any more progress on .exe info problem?.
[stevieb]: Marshall: no. I commented on the thread yesterday. Visual Studio updates the tags ok, but corrupts the exe
[stevieb]: I advised the OP that a possible workaround would be to add a version function/flag that displays the required copyright/license info instead
[Marshall]: Darn! I'll look at the thread. Must not be updatinga byte count somewhere. The .exe format is a complex critter.
[stevieb]: that way, it's still "hard coded" into the exe at least, despite not being visible via Properties
[Marshall]: I also looked into PerlApp from Active State, but they don't sell their Dev Kit independent of a very expensive ($1,200) per year license anymore.

How do I use this? | Other CB clients
Other Users?
Others cooling their heels in the Monastery: (9)
As of 2016-12-08 18:14 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    On a regular basis, I'm most likely to spy upon:













    Results (144 votes). Check out past polls.