Beefy Boxes and Bandwidth Generously Provided by pair Networks
Problems? Is your data what you think it is?
 
PerlMonks  

Re: QT 2.3.0 Bindings

by perlmonkey (Hermit)
on May 05, 2001 at 04:02 UTC ( #78168=note: print w/ replies, xml ) Need Help??


in reply to QT 2.3.0 Bindings

The QT binding on CPAN are for qt-1.44. The 2.x API has significant changes, so they old bindings wont work. I did some searching a while ago, and it seems we are both SOL. I read a few messages saying the original author was not responding to emails, and that nobody had taken ownership of perl Qt. I had grandiose plans to do it myself, but of course time always runs short. I know there are bindings for python, and I think even ruby, but no perl (that I have found).


Comment on Re: QT 2.3.0 Bindings
Re: Re: QT 2.3.0 Bindings
by awwaiid (Friar) on May 06, 2001 at 00:34 UTC

    The bindings on CPAN claim to work for qt-2.0 - you have to change the Makefile.PL, but it appears to be a supported feature. I recently installed qt-2.3. Do you know if there are once again major changes, or if perhaps I just didn't compile QT for compatability?

    When compiling PerlQT for qt-2.0 it got really far in the compilation process, which made me hopefull.

      I just played with it again and got it working with my Qt-2.2.2, so I assume it will work with qt-2.3.0 also. To get it to work you have to uncomment out the $MAKE = 'Qt-2.0'; line in the Makefile.PL. Then it did not fully compile for me caused by some missing symbols from $QTDIR/include/qnamespace.h. My errors were:
      pig_Qt.c:355: `WState_FontFixed' is not a member of type `Qt' pig_Qt.c:356: `WState_FontSet' is not a member of type `Qt' pig_Qt.c:361: `WState_PaletteFixed' is not a member of type `Qt' pig_Qt.c:362: `WState_PaletteSet' is not a member of type `Qt' pig_Qt.c:366: `WState_USPositionX' is not a member of type `Qt' pig_Qt.c:368: `WState_Withdrawn' is not a member of type `Qt' pig_Qt.c:378: `WStyle_Reserved2' is not a member of type `Qt' pig_Qt.c:379: `WStyle_Reserved3' is not a member of type `Qt' gmake: *** [pig_Qt.o] Error 1
      To fix these I just had to go into pig_Qt.c and comment out the lines with the missing sybmols listed above. Afterthat, it finished the compile. I did the make install. Then I ran through every one of the tutorial programs in the tutorials-2.0 directory and they all worked perfectly.
      So, delightfully, I was wrong, the author apparently had it working for at least some version so qt-2.x and hopefully it should not take too much tweaking to get your version to work.
      Good luck.

        Awesome! Thats exactly what I wanted to hear -- I was on my way to start doing some commenting before deciding to seek advice here, in fact. Good job :)

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://78168]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others imbibing at the Monastery: (7)
As of 2014-08-23 06:40 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (172 votes), past polls