Beefy Boxes and Bandwidth Generously Provided by pair Networks
Pathologically Eclectic Rubbish Lister
 
PerlMonks  

Re: use strict

by FunkyMonk (Canon)
on Jan 26, 2010 at 15:59 UTC ( #819705=note: print w/replies, xml ) Need Help??


in reply to use strict

It will come "free" with use 5.11; onwards.

From use in http://perl5.git.perl.org/perl.git/blob_plain/HEAD:/pod/perl5114delta.pod:

Also, if the specified Perl version is greater than or equal to 5.9.5, "use VERSION" will also load the "feature" pragma and enable all features available in the requested version. See feature. Similarly, if the specified Perl version is greater than or equal to 5.11.0, strictures are enabled lexically as with "use strict" (except that the strict.pm file is not actually loaded).

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://819705]
help
Chatterbox?
[holli]: Can somebody identify this connector?

How do I use this? | Other CB clients
Other Users?
Others surveying the Monastery: (3)
As of 2017-11-19 14:15 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In order to be able to say "I know Perl", you must have:













    Results (281 votes). Check out past polls.

    Notices?