Beefy Boxes and Bandwidth Generously Provided by pair Networks
Pathologically Eclectic Rubbish Lister
 
PerlMonks  

Re^2: Which prerequisite packages should you have installed before building Perl on GNU/Linux?

by Anonymous Monk
on Oct 04, 2010 at 02:16 UTC ( #863223=note: print w/replies, xml ) Need Help??


in reply to Re: Which prerequisite packages should you have installed before building Perl on GNU/Linux?
in thread Which prerequisite packages should you have installed before building Perl on GNU/Linux?

Thanks, ambrus.

If all you want to install is the perl core, you don't need libncurses or libreadline, for nothing in the core wants to use these. Certainly nothing like sqlite, gdbm, Tk is needed.

Well, I want Perl to utilize as many extensions as it can.

When I build Python, it tries to tell me what parts it failed to find. I've had the experience with Python where I wanted to use some piece of it's std lib (say, sqlite) and then came to find out that I didn't have the sqlite-dev package installed when I built it so I had to rebuild. I was looking for a way to avoid this experience with Perl.

  • Comment on Re^2: Which prerequisite packages should you have installed before building Perl on GNU/Linux?

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://863223]
help
Chatterbox?
LanX has to go go/
[holli]: baba

How do I use this? | Other CB clients
Other Users?
Others meditating upon the Monastery: (11)
As of 2017-11-20 20:02 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    In order to be able to say "I know Perl", you must have:













    Results (293 votes). Check out past polls.

    Notices?