Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Re: IIS 6 x64 CGI variable problem

by andal (Friar)
on Dec 24, 2010 at 08:28 UTC ( #878998=note: print w/ replies, xml ) Need Help??


in reply to IIS 6 x64 CGI variable problem

Usually, the form fields show up in the URL only when the submit method of the form was "GET" instead of "POST". First make sure that generated form explicitly requests the method "POST". Just view the HTML source of the form. If the submit method is "POST" but you get variables in the URL, then it is bug of the browser. But if you don't specify the method (it should default to GET then) or the method is not POST, then it is bug of the form generator.


Comment on Re: IIS 6 x64 CGI variable problem
Re^2: IIS 6 x64 CGI variable problem
by karlk123 (Novice) on Dec 24, 2010 at 18:51 UTC
    I am using the post method. That's why this is baffling.
    <form method="post" action="http://mysite.com/pgm.pl" enctype="multipa +rt/form-data" name="labcal" id="labcal">

    And it works fine on x32 Apache and IIS6 servers, just the IIS6 x64 server shows this symptom. It can't be a browser error as both IE7 and FF3.6 exhibit this.

    I am using some javascript too, but I don't think it's the cause. This IIS6 x64 server consistently appends the prior submit vars on the second submit button action.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://878998]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others drinking their drinks and smoking their pipes about the Monastery: (9)
As of 2014-07-25 10:41 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    My favorite superfluous repetitious redundant duplicative phrase is:









    Results (170 votes), past polls