Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl Monk, Perl Meditation
 
PerlMonks  

Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE

by hsmyers (Canon)
on May 15, 2011 at 00:03 UTC ( #904894=perlquestion: print w/ replies, xml ) Need Help??
hsmyers has asked for the wisdom of the Perl Monks concerning the following question:

In order to get out from under my current 'FAIL' from the PAUSE testing system, I need to duplicate the problematic environment---Linux running Perl 5.8.1. I've got a spare laptop that I can convert, a relatively new Ubuntu CD so the remaining question is where would I go to find an install of 5.8.1? And for that matter, advice on how to install it would be a really, really good thing(TM)

UPDATE: An abundance of thanks to all of you. With what has been posted, I should be able to get set up. I am, just maybe, being a little compulsive about this, but it used to work, and I'd like to return to that state. Most of the report deals with a warning that suggests that I don't yet have a portable way of finding related files to the module (Chess::PGN::EPD) as yet. The single error is strange enough that I want to investigate it---result of an 'is' comes back transposed and therefore fails. Which raises my eyebrows if nothing else :)

--hsm

"Never try to teach a pig to sing...it wastes your time and it annoys the pig."

Comment on Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE
Re: Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE
by FunkyMonk (Canon) on May 15, 2011 at 00:39 UTC
    where would I go to find an install of 5.8.1
    Generally, use perlhist to find out who released it, do a s/name in perlhist/cpan name/ and if you're really lucky with the substitution you'll come up with jarkko and from there you get this.

    update: That was poor advice, sorry. Use the other locations mentioned by the Monks below.

    Or, get a hold of Git and clone the perl repository.

    how to install it
    Although I've never tried 5.8.1 specifically, I've found Devel::PatchPerl does a really good job for older perls

    Update

    I cannot recommend VirtualBox highly enough if you want to play around with new OS installs.

Re: Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE
by ww (Bishop) on May 15, 2011 at 01:10 UTC
    Depending on the version (vintage) of Ubuntu, you may well find 5.8.1 on the CD (in the standard install).

    Failing that, http://packages.ubuntu.com/{Your Ubuntu version name}/libwww-perl may get you to a pre-compiled source; another possibility is exploring Debian respositories.

Re: Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE
by ikegami (Pope) on May 15, 2011 at 01:36 UTC
    Maybe if we took a quick look... Module? Link to report?
Re: Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE
by toolic (Chancellor) on May 15, 2011 at 02:37 UTC
    While I certainly commend you for your diligence -- and perhaps you've already considered this -- but it is possible that your module sensitizes a bug in perl 5.8.1. The CPAN Tester results for Chess::PGN::EPD (0.28) currently show PASS (132) FAIL (1) with the only fail on 5.8.1.

    I also looked at the reports for the previous 10 or so versions of this module, and there are no results for perl 5.8.1. It would have been useful to have at least one other data point, but no such luck.

Re: Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE
by trwww (Priest) on May 15, 2011 at 02:50 UTC

    Here is where you find old perls:

    http://www.cpan.org/src/5.0/

    This page is pretty helpful too:

    http://www.cpan.org/src

    Installing perl from source is really easy:

    $ wget http://www.cpan.org/src/5.0/perl-5.8.1.tar.gz $ tar -zxf perl-5.8.1.tar.gz $ cd perl-5.8.1 $ sh Configure -de -Dprefix=/opt/perl-5.8.1 $ make $ make install $ export PATH="/opt/perl-5.8.1/bin:$PATH"

    Now you have a throwaway perl in /opt/perl-5.8.1.

Re: Windows type needs to set up Linux with Perl 5.8.1 to match PAUSE
by salva (Monsignor) on May 15, 2011 at 07:45 UTC
      An almost perfect example of why you (me) should use perlbrew I had tried to test under 5.8.1 on windows but sadly the program tested without flaw. (Strange thing to be sad about :) ) But my plan for my new effort is to install perlbrew and then follow it's instructions to install 5.8.1 producing a 'cake and eat it too' situation! Thanks for the reminder!

      --hsm

      "Never try to teach a pig to sing...it wastes your time and it annoys the pig."

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://904894]
Approved by ww
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (6)
As of 2014-08-30 09:29 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (292 votes), past polls