Beefy Boxes and Bandwidth Generously Provided by pair Networks
XP is just a number
 
PerlMonks  

Re: 'perl -le' not working on the command line

by Bloodnok (Vicar)
on May 26, 2011 at 10:48 UTC ( #906803=note: print w/ replies, xml ) Need Help??


in reply to 'perl -le' not working on the command line

As the AM has already indicated, the fault lies with the shell, or what Windoze chooses to call it.

The 'shell' ignores, or appears not to recognise, single quotes - try enclosing your CLI command in double quotes ...

perl -Mbignum -le "print 2**255;"
As I haven't had a Windoze box for quite a while, I can't actually demonstrate this.

A user level that continues to overstate my experience :-))


Comment on Re: 'perl -le' not working on the command line
Download Code
Re^2: 'perl -le' not working on the command line
by ikegami (Pope) on May 26, 2011 at 16:07 UTC
    If I passed C source code to perl, the resulting error is not Perl's fault. Similarly, the error that results from presenting cmd with a bash command is not the shell's fault.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://906803]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (9)
As of 2014-08-21 08:32 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (128 votes), past polls