Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight
 
PerlMonks  

script fails loading module version, but > version is installed

by Allasso (Scribe)
on Jun 30, 2011 at 03:01 UTC ( #912074=perlquestion: print w/ replies, xml ) Need Help??
Allasso has asked for the wisdom of the Perl Monks concerning the following question:

Hello,

just installed W3C validator, and all the required perl modules and additional software. When I run a test I get this:

path.../httpd/cgi-bin/check uri=http://www.w3.org/ CGI version 3.4 required--this is only version 3.05 at /Library/WebSer +ver/Documents/validator/httpd/cgi-bin/check line 44. BEGIN failed--compilation aborted at /Library/WebServer/Documents/vali +dator/httpd/cgi-bin/check line 44.
However, I installed CGI version 3.55, which went without a hitch.

Anyone know why I would get an error like this?

Thanks.

Comment on script fails loading module version, but > version is installed
Download Code
Re: script fails loading module version, but > version is installed
by Allasso (Scribe) on Jun 30, 2011 at 04:27 UTC
    A little background:

    Installed per the instructions lined out here:

    http://validator.w3.org/docs/install.html#install-prereq

    installed modules manually - I tried install Bundle::W3C::Validator but it didn't work.
Re: script fails loading module version, but > version is installed
by Anonymous Monk on Jun 30, 2011 at 04:29 UTC

    Anyone know why I would get an error like this?

    You're not using the same perl

    or you installed CGI 3.55 in a location perl doesn't know about

    or you installed CGI 3.55 in a directory perl (when running under the user account of your webserver) cannot access

    or something else like that

      You're not using the same perl

      ?

      or you installed CGI 3.55 in a location perl doesn't know about

      or you installed CGI 3.55 in a directory perl (when running under the user account of your webserver) cannot access

      perl -e 'use CGI; print "CGI: $CGI::VERSION";' CGI: 3.55
      ?

      You're not using the same perl

      I put this at the top of the script being run:
      print "PERL VERSION : "; print `perl -v`; print "\n"; __END__
      it prints this:
      PERL VERSION : This is perl, v5.8.8 built for darwin-2level blah blah...
      - same as the version I am running with -e on the command line...

      I don't know what other perl I could be running.

        Output %INC resp. $INC{"CGI.pm"} in the good and the bad case to see which file gets loaded from where.

        I don't know what other perl I could be running.

        You're not checking to see which perl you're running

        $ perl -e " die $^X" C:\perl\5.12.2\bin\MSWin32-x86-multi-thread\perl.exe at -e line 1.

        Similarly compare %ENV, INC, %INC

        Some have installed 85+ different perls

Re: script fails loading module version, but > version is installed
by Anonymous Monk on Jun 30, 2011 at 05:07 UTC
    Hi,

    I think you may have 2 versions of CGI installed, and your perl is still pointing at the old one.

    Try searching for CGI and see what you get.

    J.C.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://912074]
Approved by ww
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others examining the Monastery: (9)
As of 2015-07-06 08:55 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (70 votes), past polls