Beefy Boxes and Bandwidth Generously Provided by pair Networks
Don't ask to ask, just ask
 
PerlMonks  

Re^3: LWP::Useragent GET fails with https

by wazoox (Prior)
on Oct 18, 2011 at 16:49 UTC ( #932194=note: print w/ replies, xml ) Need Help??


in reply to Re^2: LWP::Useragent GET fails with https
in thread LWP::Useragent GET fails with https

There was a slight mistake in my code example:

$ENV{HTTPS_PROXY} = 'http://proxy:8080';
Note the absence of trailing slash. It works for me, I've just got it running through my local squid proxy:
[~/temp]$ ./test.pl SSL_connect:before/connect initialization SSL_connect:SSLv2/v3 write client hello A SSL_connect:SSLv3 read server hello A SSL_connect:SSLv3 read server certificate A SSL_connect:SSLv3 read server done A SSL_connect:SSLv3 write client key exchange A SSL_connect:SSLv3 write change cipher spec A SSL_connect:SSLv3 write finished A SSL_connect:SSLv3 flush data SSL_connect:SSLv3 read finished A Successtext/htmlcharset=ISO-8859-1 document!

Please provide more information on your configuration. It works fine for me on Linux, running Perl 5.10.1 and LWP 5.835.


Comment on Re^3: LWP::Useragent GET fails with https
Select or Download Code

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://932194]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chanting in the Monastery: (8)
As of 2015-07-02 05:58 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The top three priorities of my open tasks are (in descending order of likelihood to be worked on) ...









    Results (29 votes), past polls