Beefy Boxes and Bandwidth Generously Provided by pair Networks
XP is just a number
 
PerlMonks  

Re^3: Arguments for upgrading from Perl 5.8

by chromatic (Archbishop)
on Nov 17, 2011 at 22:20 UTC ( #938691=note: print w/replies, xml ) Need Help??


in reply to Re^2: Arguments for upgrading from Perl 5.8
in thread Arguements for upgrading from Perl 5.8

Only as of 5.14 are most of the builtin operations fully aware of Unicode; too many of them default to assuming the semantics of whatever the local character set is. unicode mentions this as "The Unicode Bug". Perl 5.12 fixed some of that, but only as of Perl 5.14 can you use use feature 'unicode_strings'; to get Perl to do the right thing.

I haven't encountered huge problems in my work, but most of what I do uses nothing more exotic than Latin-1 and UTF-8, so I've been fortunate. Then again, everything I care about runs on Perl 5.14.1 (and soon Perl 5.14.2).


Improve your skills with Modern Perl: the free book.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://938691]
help
Chatterbox?
[1nickt]: They assume that I want things I don;t and don;t provide things I do want. Looking for a 17" laptop with 4k (even 3K display) and full numeric-pad keyboard.
[1nickt]: They assume that if I want a 17" monitor I could not possibly want 4k screen
[1nickt]: They assume I do not need a DVD drive
[1nickt]: Heh, or they assume that if I want all that I am a "gamer" and I must want red backlighting for the keyboards and that I will pay $3500 ...
[stevieb]: what is your budget? HP 17" 4k display, DVD writer, full numeric keypad
[stevieb]: $1500 USD

How do I use this? | Other CB clients
Other Users?
Others studying the Monastery: (5)
As of 2017-03-26 18:06 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?
    Should Pluto Get Its Planethood Back?



    Results (315 votes). Check out past polls.