Beefy Boxes and Bandwidth Generously Provided by pair Networks
Welcome to the Monastery
 
PerlMonks  

Re^5: "Invisible" nodes (details)

by tye (Cardinal)
on Jan 06, 2012 at 15:39 UTC ( #946616=note: print w/ replies, xml ) Need Help??


in reply to Re^4: "Invisible" nodes (core)
in thread "Invisible" nodes

Yes, Clean smoke-test install for Inline based modules using Inline::MakeMaker results in a blank page when I'm logged in as tye and access it via that web server as well (that web server is the "new" one that has mod_perl v2). Each visit adds the following to the error log:

[...] [notice] child pid 45490 exit signal Illegal instruction (4)

This doesn't happen if I view it when not logged in or even when I view it logged in as tye .

One of the factors that is often present in previous cases I've seen of this is the presense of a node by BrowserUk where he uses "<spoiler><code>", Re^5: Clean smoke-test install for Inline based modules using Inline::MakeMaker. But there have been other such nodes where this bug doesn't happen and there have been nodes that trigger this bug where that string is not used.

Since both tye and tye&nbsp; have the same settings for how to handle spoilers, I just now spent some time changing some of my "code wrap" settings. I can make the bug appear or disappear by changing several of those. A common element might be that settings that insert HTML tags for CODE sections trigger the bug? In any case, I can trigger the bug for that node if I turn on "auto code wrap" and set the wrap length to 10. I can also trigger the bug there if I use your "code prefix" that contains several HTML tags.

I suspect that Perl's "safe signals" would prevent me from trapping SIGILL so that I could get a stack trace of where the bug fires. "man signal" on this OS doesn't say that I can't trap SIGILL like "man signal" says on my work box does, so it might be worth trying. Makes me want to be able to pick between "safe" and "unsafe" signals in Perl on a per-signal basis. I don't think Perl supports that but I suspect the underlying mechanism Perl uses could support that.

BTW, adding ;spoil=1 to the URL doesn't prevent the bug.

So that is some more specific information than I had before. Still doesn't give me a simple troubleshooting route, unfortunately. I don't have more time to look at that right now, but I might find some time to look further fairly soon.

- tye        


Comment on Re^5: "Invisible" nodes (details)
Select or Download Code
Re^6: "Invisible" nodes (details)
by roboticus (Canon) on Jan 06, 2012 at 16:28 UTC

    tye:

    Don't hurry to fix it on my account, I just wanted to give you what you needed to reproduce it if needed. Thanks for the ";spoil=1" workaround, I'll use that when I need it.

    Thank you...

    ...roboticus

    When your only tool is a hammer, all problems look like your thumb.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://946616]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others wandering the Monastery: (6)
As of 2014-08-28 03:30 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The best computer themed movie is:











    Results (255 votes), past polls