Beefy Boxes and Bandwidth Generously Provided by pair Networks
Clear questions and runnable code
get the best and fastest answer
 
PerlMonks  

Re^3: exec not working?

by GrandFather (Cardinal)
on Jan 30, 2012 at 04:07 UTC ( #950694=note: print w/ replies, xml ) Need Help??


in reply to Re^2: exec not working?
in thread exec not working?

Did you close and restart whatever "session" you were running your scripts from following the Perl install and include path change? The session's version of the include path wouldn't be affected by any changes made outside the session or any changes made in child sessions.

True laziness is hard work


Comment on Re^3: exec not working?
Re^4: exec not working?
by UVB (Acolyte) on Jan 31, 2012 at 02:57 UTC
    Yes - definitely. After some experimentation - and with careful changes to path environment - checking that path has been reloaded prior to running perl - I have found: v5.12.0 will work. v5.12.3 won't work. In both cases I am reasonably confident that there is only one perl.exe on the path at any one time. In both cases 'system' does work correctly with the same parameters as given to 'exec'. I am not saying there is a bug - just commenting on my experience in my installation. Thanks, Ross.

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://950694]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (12)
As of 2014-09-19 21:06 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    How do you remember the number of days in each month?











    Results (146 votes), past polls