Beefy Boxes and Bandwidth Generously Provided by pair Networks
Perl: the Markov chain saw
 
PerlMonks  

install_driver(Oracle) failed: Can't locate loadable object for module DBD::Orac le in @INC

by suneel.reddy (Novice)
on May 08, 2012 at 10:47 UTC ( #969413=perlquestion: print w/ replies, xml ) Need Help??
suneel.reddy has asked for the wisdom of the Perl Monks concerning the following question:

Hi Monks,

while executing my perl exe file , I'm getting an error - "install_driver(Oracle) failed: Can't locate loadable object for module DBD::Orac le in @INC".

Im running ActivePerl - 5.14.2 , which has DBD installed by default on my Windows XP

I'm new to this and its urgent ,Can someone please help me solving this ?

Thanks in advance...

Comment on install_driver(Oracle) failed: Can't locate loadable object for module DBD::Orac le in @INC
Replies are listed 'Best First'.
Re: install_driver(Oracle) failed: Can't locate loadable object for module DBD::Orac le in @INC
by Corion (Pope) on May 08, 2012 at 10:58 UTC

      Yes, I tried with google, but I didn't see any post helping me. All posts are pointing to 5.8.8 or lesser versions where DBD had to be installed manually , But I'm using 5.14.2 which has this module by default. I even verified it through PPM and found it in the list.

      Any way to find it was installed properly or not?

        DBD::Oracle is just the perl module, but it still requires either a full database installation or an Oracle-client installation. The message possibly stems from the shared object of the perl module not able to find the Oracle client libraries. I know how to show what Oracle.so expects on Linux/Unix, but I have no idea how to show that on Windows.

        Did you install the Oracle client where DBD::Oracle expects it? Dit you read the documentation for win64/win32 about the prerequisites?


        Enjoy, Have FUN! H.Merijn

        No.

        Perl does not come with Oracle "by default". Maybe your Perl distribution comes with DBD::Oracle, but you will still need to install the Oracle client libraries. See the articles I linked, which all explain this and tell you what to do.

Re: install_driver(Oracle) failed: Can't locate loadable object for module DBD::Orac le in @INC
by marto (Bishop) on May 08, 2012 at 10:57 UTC

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: perlquestion [id://969413]
Approved by marto
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others pondering the Monastery: (4)
As of 2015-08-05 02:43 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    The oldest computer book still on my shelves (or on my digital media) is ...













    Results (76 votes), past polls