Beefy Boxes and Bandwidth Generously Provided by pair Networks
Syntactic Confectionery Delight

Re^3: What is a really old version of Perl? (you lost)

by tobyink (Abbot)
on Jun 26, 2012 at 05:50 UTC ( #978338=note: print w/replies, xml ) Need Help??

in reply to Re^2: What is a really old version of Perl? (you lost)
in thread What is a really old version of Perl?

My point is not that nobody should run 5.8, but rather than nobody should run 5.8 and expect to be able to download recently written code and have it "just work".

Using a legacy version of Perl to run legacy code (and I understand it, there's a picture of the Perlmonks code if you look up "legacy code" in the dictionary) is clearly fine.

Perl 5.8 first came into this world in 2002; the same year as Windows XP. The latest releases of Internet Explorer don't run on Windows XP. If one of the largest commercial software developers on the planet will not support products 10 years old that have had multiple stable releases since, then why should unpaid open source developers?

perl -E'sub Monkey::do{say$_,for@_,do{($monkey=[caller(0)]->[3])=~s{::}{ }and$monkey}}"Monkey say"->Monkey::do'
  • Comment on Re^3: What is a really old version of Perl? (you lost)

Replies are listed 'Best First'.
Re^4: What is a really old version of Perl? (you lost)
by jgamble (Pilgrim) on Jun 26, 2012 at 16:56 UTC

    Sure, but combine that with the oft-heard statement, "I don't program in perl, I program in CPAN."

    I only recently changed my CPAN packages from requiring perl 5.6 to requiring perl 5.8.3. Not because my code requires it, but because the Build/Make utilities are finally dropping support for pre-5.8 perls. (Note that I'm referring to the "requires" key in Build.PL or Makefile.PL, not in the module source itself.)

    Now for many, probably most, packages that goes back ridiculously far back, but I don't write OS- or WWW-specific packages, and I have no reason not to support as many people as possible.

    I suppose you could start a campaign to force people to upgrade their perls by using the requires keyword with perl => 5.16 (for example), but I frankly don't see the point. Set the minimum version to what's needed, and let the end-users sort it out.

Log In?

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://978338]
and all is quiet...

How do I use this? | Other CB clients
Other Users?
Others cooling their heels in the Monastery: (6)
As of 2017-11-25 01:18 GMT
Find Nodes?
    Voting Booth?
    In order to be able to say "I know Perl", you must have:

    Results (355 votes). Check out past polls.