Sure, but combine that with the oft-heard statement, "I don't program in perl, I program in CPAN."
I only recently changed my CPAN packages from requiring perl 5.6 to requiring perl 5.8.3. Not because my code requires it, but because the Build/Make utilities are finally dropping support for pre-5.8 perls. (Note that I'm referring to the "requires" key in Build.PL or Makefile.PL, not in the module source itself.)
Now for many, probably most, packages that goes back ridiculously far back, but I don't write OS- or WWW-specific packages, and I have no reason not to support as many people as possible.
I suppose you could start a campaign to force people to upgrade their perls by using the requires keyword with perl => 5.16 (for example), but I frankly don't see the point. Set the minimum version to what's needed, and let the end-users sort it out.