in reply to Re^2: Parsing Data in xlsx file
in thread Parsing Data in xlsx file
After glancing at your code, I'd suggest you sanitize it a bit. By sanitize, I don't mean "clean up"--I mean "make less insane". If you name a function readhash I would expect that it would do something like, say, reading a hash from some source. I certainly wouldn't expect it to write a spreadsheet. Perhaps naming it something like "write_spreadsheet" would be less confusing?
When your only tool is a hammer, all problems look like your thumb.