Beefy Boxes and Bandwidth Generously Provided by pair Networks
Keep It Simple, Stupid
 
PerlMonks  

Re^2: How to resolve issue "Can't load module Fcntl, dynamic loading not available in this perl" in perl 5.16 during building XML parser

by sridhar84 (Novice)
on Aug 28, 2012 at 08:28 UTC ( #990172=note: print w/ replies, xml ) Need Help??


in reply to Re: How to resolve issue "Can't load module Fcntl, dynamic loading not available in this perl" in perl 5.16 during building XML parser
in thread How to resolve issue "Can't load module Fcntl, dynamic loading not available in this perl" in perl 5.16 on HP-UX during building XML parser module

Thanks for quick attention. I am building perl 5.16 from source and using perl 5.16 interpreter building all perl modules from source. For XML parser module i am getting this error.. other modules are building fine.


Comment on Re^2: How to resolve issue "Can't load module Fcntl, dynamic loading not available in this perl" in perl 5.16 during building XML parser
Re^3: How to resolve issue "Can't load module Fcntl, dynamic loading not available in this perl" in perl 5.16 during building XML parser
by Corion (Pope) on Aug 28, 2012 at 08:31 UTC

    But miniperl is substantially different from perl. If you are building Perl from source, enable dynamic loading (this is the default), and use perl, not miniperl. miniperl never has dynamic loading. It's one of the things that makes miniperl "mini".

      Thanks a lot. it worked for me.
      Thanks a lot. it worked for me.
Re^3: How to resolve issue "Can't load module Fcntl, dynamic loading not available in this perl" in perl 5.16 during building XML parser
by Anonymous Monk on Aug 28, 2012 at 08:36 UTC

    From what source (libovperl.so/XML::Parser aren't standard)?

    Are you building a dynamic perl ( is usedl true)? What is your configure invocation?

Re^3: How to resolve issue "Can't load module Fcntl, dynamic loading not available in this perl" in perl 5.16 during building XML parser
by Tux (Monsignor) on Aug 28, 2012 at 08:56 UTC

    I already have a working perl-5.16.0 depot available for HP-UX. Look here and here.

    I see you want a 32bit perl. Why? Most targets - like Oracle - on 11.23/IPF are 64bits.


    Enjoy, Have FUN! H.Merijn

Log In?
Username:
Password:

What's my password?
Create A New User
Node Status?
node history
Node Type: note [id://990172]
help
Chatterbox?
and the web crawler heard nothing...

How do I use this? | Other CB clients
Other Users?
Others chilling in the Monastery: (8)
As of 2014-09-18 21:24 GMT
Sections?
Information?
Find Nodes?
Leftovers?
    Voting Booth?

    How do you remember the number of days in each month?











    Results (124 votes), past polls